Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453271 - rpm -V xml-common complains about /usr/share/sgml/docbook/xmlcatalog
Summary: rpm -V xml-common complains about /usr/share/sgml/docbook/xmlcatalog
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: sgml-common
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ondrej Vasik
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-28 18:25 UTC by Christian Krause
Modified: 2008-07-02 22:40 UTC (History)
0 users

Fixed In Version: 0.6.3-24.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-01 05:31:06 UTC


Attachments (Terms of Use)

Description Christian Krause 2008-06-28 18:25:34 UTC
Description of problem:
"rpm -V xml-common" complains about the following problem:

Package xml-common-0.6.3-23.fc9.noarch:
S.5....T  c /etc/xml/catalog
S.5....T    /usr/share/sgml/docbook/xmlcatalog

Because it is intended that /usr/share/sgml/docbook/xmlcatalog is modified
during the installation of several packages (e.g. xml-dtd), rpm -V should not
verify the time, size and md5 sum.

Similar problems existed in other packages and were solved using something like
this in the spec file:
"%ghost %verify(not size mtime md5) %{_datadir}/..."

A short discussion about this topic with some explanations can be found here:
https://bugzilla.redhat.com/show_bug.cgi?id=70919#c8

Version-Release number of selected component (if applicable):
0.6.3-23.fc9

Steps to Reproduce:
1. rpm -V xml-common
  
Expected results:
- no complaints about /usr/share/sgml/docbook/xmlcatalog

Comment 1 Fedora Update System 2008-06-30 07:10:15 UTC
sgml-common-0.6.3-24.fc9 has been submitted as an update for Fedora 9

Comment 2 Ondrej Vasik 2008-06-30 07:17:31 UTC
Thanks for report, fixed in the 0.6.3-24.fc9, will get closed once the update
will reach stable.

Comment 3 Fedora Update System 2008-07-01 05:31:04 UTC
sgml-common-0.6.3-24.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 4 Christian Krause 2008-07-02 22:40:35 UTC
(In reply to comment #2)
> Thanks for report, fixed in the 0.6.3-24.fc9, will get closed once the update
> will reach stable.

I've tested the new package and the problem ist fixed. Thank you very much!




Note You need to log in before you can comment on or make changes to this bug.