Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453268 - tk.x86_64 pulls in old package of tcl.i386, and doesn't use installed new package of tcl.x86_64
Summary: tk.x86_64 pulls in old package of tcl.i386, and doesn't use installed new pac...
Keywords:
Status: CLOSED DUPLICATE of bug 453239
Alias: None
Product: Fedora
Classification: Fedora
Component: tk
Version: 9
Hardware: x86_64
OS: Linux
low
medium
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-28 16:47 UTC by Mukund Sivaraman
Modified: 2008-06-30 07:20 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 07:20:17 UTC


Attachments (Terms of Use)

Description Mukund Sivaraman 2008-06-28 16:47:13 UTC
Description of problem:

tcl 8.5.2 (x86_64) is installed. I try to install tk, it pulls in tcl 8.5.1
(i386). Apps such as gitk don't work then.

[root@jurassic ~]# rpm -qa tcl
tcl-8.5.2-1.fc9.x86_64
[root@jurassic ~]# rpm -qa tk
[root@jurassic ~]# yum install tk
Loaded plugins: refresh-packagekit
emacs                                                    | 1.1 kB     00:00
primary.xml.gz                                           | 2.2 kB     00:00
emacs                                                          5/5
updates                                                  | 2.3 kB     00:00
primary.sqlite.bz2                                       | 1.9 MB     00:11
freshrpms                                                | 1.9 kB     00:00
primary.sqlite.bz2                                       | 104 kB     00:01
fedora                                                   | 2.4 kB     00:00
primary.sqlite.bz2                                       | 7.6 MB     00:43
Setting up Install Process
Parsing package install arguments
Resolving Dependencies
--> Running transaction check
---> Package tk.x86_64 1:8.5.1-4.fc9 set to be updated
--> Processing Dependency: tcl = 1:8.5.1 for package: tk
--> Running transaction check
---> Package tcl.i386 1:8.5.1-4.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size
=============================================================================
Installing:
 tk                      x86_64     1:8.5.1-4.fc9    updates           1.5 M
Installing for dependencies:
 tcl                     i386       1:8.5.1-4.fc9    fedora            2.2 M

Transaction Summary
=============================================================================
Install      2 Package(s)
Update       0 Package(s)
Remove       0 Package(s)

Total size: 3.7 M
Is this ok [y/N]: n
Exiting on user Command
Complete!


Version-Release number of selected component (if applicable):
tk-8.5.1-4.fc9

How reproducible:
Always.

Steps to Reproduce:
1. yum install tk
  
Actual results:
Old version of tcl.i386 is download and installed as a dep.

Expected results:
Existing latest version of tcl.x86_64 should be used (or downloaded and
installed) as a dep.

Comment 1 Mukund Sivaraman 2008-06-28 16:51:43 UTC
Updating title to make more sense.

Also, apps such as gitk and git-gui are broken (which is how I first noticed the
issue after a yum update). yum them complains of an existing update to tcl.i386
package (because there's one) which it can't install because tk.x86_64 depends
on the old tcl.i386 package.

It seems wrong that tcl.x86_64 should depend on tcl.i386 when both packages have
i386 and x86_64 RPMs.


Comment 2 Mukund Sivaraman 2008-06-28 16:53:24 UTC
Correction: It seems wrong that tk.x86_64 should depend on tcl.i386 when both
packages have i386 and x86_64 RPMs.


Comment 3 Marcela Mašláňová 2008-06-30 07:20:17 UTC

*** This bug has been marked as a duplicate of 453239 ***


Note You need to log in before you can comment on or make changes to this bug.