Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453258 - Tcl/Tk causes dependency problems, blocks system update
Summary: Tcl/Tk causes dependency problems, blocks system update
Keywords:
Status: CLOSED DUPLICATE of bug 453239
Alias: None
Product: Fedora
Classification: Fedora
Component: yum
Version: 9
Hardware: i686
OS: Linux
low
low
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-28 12:41 UTC by Przemek Klosowski
Modified: 2014-01-21 23:03 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 19:01:24 UTC


Attachments (Terms of Use)

Description Przemek Klosowski 2008-06-28 12:41:52 UTC
Description of problem:
Not really yum per se, but a packaging problem: cannot update the system
because of packaging dependencies error for Tcl/Tk packages, which blocks
the entire update.

The workaround is to exclude Tcl/Tk from the update process:

   yum update -x tcl* -x tk*


The system is a brand spanking new Fedora 9 install, with everything; just did
a couple of update cycles after loading from F9 DVD.



Version-Release number of selected component (if applicable):
This happens as of Sat Jun 28, 08:30 EST (relevant because the packaging
dependencies are received from the Fedora update sites as of that date)

How reproducible: very reproducible

Steps to Reproduce:
1. yum update
2. observe Error: Missing dependency messages
  
Actual results:
yum update
Loaded plugins: refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package tcl-devel.i386 1:8.5.2-1.fc9 set to be updated
--> Processing Dependency: tcl = 1:8.5.1 for package: tk
--> Processing Dependency: tcl-devel = 1:8.5.1 for package: tk-devel
---> Package tcl.i386 1:8.5.2-1.fc9 set to be updated
--> Finished Dependency Resolution
1:tk-devel-8.5.1-4.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: tcl-devel = 1:8.5.1 is needed by package
1:tk-devel-8.5.1-4.fc9.i386 (installed)
1:tk-8.5.1-4.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-4.fc9.i386 (installed)
Error: Missing Dependency: tcl-devel = 1:8.5.1 is needed by package
1:tk-devel-8.5.1-4.fc9.i386 (installed)
Error: Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-4.fc9.i386 (installed)


Expected results:
Of course I expected a successful yum update

Comment 1 Andre Robatino 2008-06-28 16:40:56 UTC
This appears to be a duplicate of bug #453239.

Comment 2 Greg Martyn 2008-06-29 04:03:05 UTC
I agree that it's a dupe. "only the owner or submitter of the bug, or a
authorized user, may" mark it as a duplicate though

Comment 3 Przemek Klosowski 2008-06-30 19:01:24 UTC

*** This bug has been marked as a duplicate of 453239 ***


Note You need to log in before you can comment on or make changes to this bug.