Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453243 - KCrash doesn't work for KDE 3 apps in KDE 4 session
Summary: KCrash doesn't work for KDE 3 apps in KDE 4 session
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdelibs3
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kevin Kofler
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-28 10:13 UTC by Kevin Kofler
Modified: 2008-07-06 06:16 UTC (History)
4 users (show)

Fixed In Version: 3.5.9-16.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-06 06:16:11 UTC


Attachments (Terms of Use)

Description Kevin Kofler 2008-06-28 10:13:23 UTC
Description of problem:
KCrash doesn't show up for crashes of KDE 3 (kdelibs3) applications in a KDE 4 
session. Instead, a message "KCrash cannot reach kdeinit, launching directly." 
shows up, then the application exits.

Version-Release number of selected component (if applicable):
kdelibs3-3.5.9-15.fc9.x86_64
kdelibs-4.0.5-4.fc9.x86_64
kdebase-workspace-4.0.5-3.fc9.x86_64

How reproducible:
Always

Steps to Reproduce:
1. kile & (or any other KDE 3 app)
2. killall -SIGABRT kile
  
Actual results:
KCrash: Application 'kile' crashing...
KCrash cannot reach kdeinit, launching directly.

[1]+ Exit 253                 kile

Expected results:
The KCrash dialog shows up.

Additional info:
I'll see if I can figure out what's wrong, if not, I'll bring this up at the 
next meeting.

Comment 1 Kevin Kofler 2008-06-28 10:23:28 UTC
I figured it out: it wants to start drkonqi, however it can't start the KDE 3 
drkonqi because we're disabling it with DO_NOT_COMPILE in kdebase3 and it can't 
start the KDE 4 one because it's in /usr/libexec/kde4.

So I see 2 solutions: either we reenable the KDE 3 drkonqi or we try patching 
kdelibs3 so it execs the KDE 4 one instead. (Not sure if that works.)

(Grrr, yet another KDE 3 app feature broken by excess DO_NOT_COMPILE in 
kdebase3...)

Comment 2 Kevin Kofler 2008-06-28 10:28:03 UTC
Or third solution: we ln -s /usr/libexec/kde4/drkonqi /usr/bin/drkonqi in 
kdebase-runtime. (I just tested, that works.)

Comment 3 Fedora Update System 2008-07-02 08:02:16 UTC
kdelibs3-3.5.9-16.fc9 has been submitted as an update for Fedora 9

Comment 4 Fedora Update System 2008-07-03 03:18:01 UTC
kdelibs3-3.5.9-16.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kdelibs3'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-6068

Comment 5 Fedora Update System 2008-07-06 06:16:09 UTC
kdelibs3-3.5.9-16.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.