Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453240 - New tcl update has internal inconsistency
Summary: New tcl update has internal inconsistency
Keywords:
Status: CLOSED DUPLICATE of bug 453302
Alias: None
Product: Fedora
Classification: Fedora
Component: tcl
Version: 9
Hardware: All
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-28 06:48 UTC by Kevin J. Cummings
Modified: 2008-06-30 08:15 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 08:15:15 UTC


Attachments (Terms of Use)

Description Kevin J. Cummings 2008-06-28 06:48:03 UTC
Description of problem:
The new tcl just released (1:8.5.2-1.fc9) has the following line in
/usr/share/tcl8.5/init.tcl on line 20:

package require -exact Tcl 8.5.1


Version-Release number of selected component (if applicable):
1:8.5.2-1.fc9

How reproducible:
always


Steps to Reproduce:
1. I ran pysol (from PySolFC
2.
3.
  
Actual results:
Traceback (most recent call last):
  File "/usr/share/PySolFC/pysol.py", line 26, in <module>
    init()
  File "/usr/lib/python2.5/site-packages/pysollib/init.py", line 118, in init
    root = Tkinter.Tk(className=settings.TITLE)
  File "/usr/lib64/python2.5/lib-tk/Tkinter.py", line 1636, in __init__
    self.tk = _tkinter.create(screenName, baseName, className, interactive,
wantobjects, useTk, sync, use)
_tkinter.TclError: Can't find a usable init.tcl in the following directories: 
    /usr/share/tcl8.5 /usr/lib/tcl8.5 /lib/tcl8.5 /usr/library /library
/tcl8.5.2/library /tcl8.5.2/library

/usr/share/tcl8.5/init.tcl: version conflict for package "Tcl": have 8.5.2, need
exactly 8.5.1
version conflict for package "Tcl": have 8.5.2, need exactly 8.5.1
    while executing
"package require -exact Tcl 8.5.1"
    (file "/usr/share/tcl8.5/init.tcl" line 20)
    invoked from within
"source /usr/share/tcl8.5/init.tcl"
    ("uplevel" body line 1)
    invoked from within
"uplevel #0 [list source $tclfile]"



Expected results:
I expected pysol to run correctly

Additional info:

Comment 1 Nicolas A. Barriga 2008-06-28 15:58:16 UTC
This seems to be a duplicate of bug #453239

Comment 2 Kevin J. Cummings 2008-06-29 02:38:10 UTC
Nope.  Different problems with the same tcl RPM.  453239 claims that tk is not
compatible with this release.  This bug claims that tcl is not compatible with
itself.   B^)


Comment 3 Kevin J. Cummings 2008-06-29 06:05:42 UTC
I just installed tcl.x86_64 1:8.5.2-2.fc9 and it seems to fix this problem.

However, it was a pain to install because bug #453239 still has not been resolved.


Comment 4 Marcela Mašláňová 2008-06-30 08:15:15 UTC

*** This bug has been marked as a duplicate of 453302 ***


Note You need to log in before you can comment on or make changes to this bug.