Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453239 - Tk is out of sync with tcl.
Summary: Tk is out of sync with tcl.
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: tk
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Marcela Mašláňová
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 453258 453268 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-28 05:34 UTC by Jonathan Ryshpan
Modified: 2008-06-30 19:01 UTC (History)
11 users (show)

Fixed In Version: tk-8.5.2-1.fc9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 07:21:54 UTC


Attachments (Terms of Use)

Description Jonathan Ryshpan 2008-06-28 05:34:07 UTC
Description of problem: The latest version of tcl just updated in the
repository, namely tcl-8.5.2-1.fc9 is not compatible with the current version of
tk in the repository, namely tk-8.5.1-4.fc9 .


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run yumex


  
Actual results:
yumex reports
22:24:46 :  Packages to update
22:24:46 :  ---> 1:tcl-8.5.2-1.fc9.i386 
22:24:46 :  ---> 1:tcl-devel-8.5.2-1.fc9.i386 
22:24:46 : Preparing for install/remove/update
22:24:46 : --> Preparing for a full update
22:24:46 : --> Running transaction check
22:24:46 : --> Processing Dependency: tcl-devel = 1:8.5.1 for package: tk-devel
22:24:46 : ---> Package tcl-devel.i386 1:8.5.2-1.fc9 set to be updated
22:24:46 : ---> Package tcl.i386 1:8.5.2-1.fc9 set to be updated
22:24:46 : --> Processing Dependency: tcl = 1:8.5.1 for package: tk
22:24:48 : --> Finished Dependency Resolution
22:24:48 : 1:tk-devel-8.5.1-4.fc9.x86_64 from installed has depsolving problems
22:24:48 :   --> Missing Dependency: tcl-devel = 1:8.5.1 is needed by package
1:tk-devel-8.5.1-4.fc9.x86_64 (installed)
22:24:48 : 1:tk-8.5.1-4.fc9.x86_64 from installed has depsolving problems
22:24:48 :   --> Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-4.fc9.x86_64 (installed)

  
Expected results:
System upgraded.

Additional info:

Comment 1 Kevin J. Cummings 2008-06-28 06:35:35 UTC
I saw this too.  On x86_64, when tcl 1:8.5.2-1.fc9 became available, yum update
installed both this tcl.x86_64 package but also 1:tcl-8.5.1-1.fc9.i386! 
Probably to satisfy the version requirement from tk.x86_64.  However, now it
wants to update the .i386 package as well, and tk won't let it.


Comment 2 Joachim Backes 2008-06-28 08:51:41 UTC
Me too:

sudo yum -y update
Loaded plugins: fastestmirror, refresh-packagekit
Loading mirror speeds from cached hostfile
 * livna: ftp-stud.fht-esslingen.de
 * fedora: ftp.esat.net
 * updates: ftp.esat.net
updates                                                  | 2.3 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package tcl.i386 1:8.5.2-1.fc9 set to be updated
--> Processing Dependency: tcl = 1:8.5.1 for package: tk
--> Finished Dependency Resolution
1:tk-8.5.1-4.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-4.fc9.i386 (installed)
Error: Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-4.fc9.i386 (installed)


Comment 3 Greg Martyn 2008-06-29 04:00:00 UTC
Same here


[root@laptop yum.repos.d]# yum upgrade
 
<blah blah blah>
 
--> Finished Dependency Resolution
1:tk-8.5.1-4.fc9.x86_64 from installed has depsolving problems
  --> Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-4.fc9.x86_64 (installed)
Error: Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-4.fc9.x86_64 (installed)
 
 
[root@laptop yum.repos.d]# yum list tcl tk
Loaded plugins: refresh-packagekit
Installed Packages
tcl.x86_64                               1:8.5.2-1.fc9          installed
tcl.i386                                 1:8.5.1-4.fc9          installed
tk.x86_64                                1:8.5.1-4.fc9          installed
Available Packages
tcl.i386                                 1:8.5.2-1.fc9          updates
tk.i386                                  1:8.5.1-4.fc9          updates

Comment 4 Samuel Sieb 2008-06-29 04:07:08 UTC
Worse than that, I got the just built version of tk from koji and it won't
upgrade.  It still complains about dependencies on the currently installed
version or something.

# yum update tk
Loaded plugins: downloadonly, refresh-packagekit
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package tk.i386 1:8.5.2-1.fc9 set to be updated
--> Processing Dependency: tcl = 1:8.5.2 for package: tk
--> Running transaction check
--> Processing Dependency: tcl = 1:8.5.1 for package: tk
---> Package tcl.i386 1:8.5.2-2.fc9 set to be updated
--> Finished Dependency Resolution
1:tk-8.5.1-3.fc9.i386 from installed has depsolving problems
  --> Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-3.fc9.i386 (installed)
Error: Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-3.fc9.i386 (installed)


Comment 5 Samuel Sieb 2008-06-29 04:14:34 UTC
Never mind, I had two copies of tk installed due to a botched upgrade at some
point.  The one from koji works fine, so updates should work as soon as it gets
out to the mirrors.

Comment 6 Jonathan Ryshpan 2008-06-29 05:59:38 UTC
tcl-8.5.2-2 is no improvement, as the extract (below) from an attempt to upgrade
to the latest tcl using yumex indicates.  When will we get the version of tk
that matches the latest tcl?

Package Queue:
22:55:45 :  Packages to update
22:55:45 :  ---> 1:tcl-8.5.2-2.fc9.x86_64 
22:55:45 :  ---> 1:tcl-8.5.2-2.fc9.i386 
22:55:45 :  ---> 1:tcl-devel-8.5.2-2.fc9.i386 
22:55:45 :  ---> 1:tcl-devel-8.5.2-2.fc9.x86_64 
22:55:45 : Preparing for install/remove/update
22:55:45 : --> Preparing for a full update
22:55:45 : --> Running transaction check
22:55:46 : --> Processing Dependency: tcl = 1:8.5.1 for package: tk
22:55:46 : ---> Package tcl.x86_64 1:8.5.2-2.fc9 set to be updated
22:55:46 : --> Processing Dependency: tcl-devel = 1:8.5.1 for package: tk-devel
22:55:46 : ---> Package tcl-devel.i386 1:8.5.2-2.fc9 set to be updated
22:55:46 : ---> Package tcl-devel.x86_64 1:8.5.2-2.fc9 set to be updated
22:55:46 : ---> Package tcl.i386 1:8.5.2-2.fc9 set to be updated
22:55:54 : --> Finished Dependency Resolution
22:55:54 : 1:tk-8.5.1-4.fc9.x86_64 from installed has depsolving problems
22:55:54 :   --> Missing Dependency: tcl = 1:8.5.1 is needed by package
1:tk-8.5.1-4.fc9.x86_64 (installed)
22:55:54 : 1:tk-devel-8.5.1-4.fc9.x86_64 from installed has depsolving problems
22:55:54 :   --> Missing Dependency: tcl-devel = 1:8.5.1 is needed by package
1:tk-devel-8.5.1-4.fc9.x86_64 (installed)

Comment 7 Samuel Sieb 2008-06-29 06:25:40 UTC
It's been built.  If you want to get it before it gets to the mirrors, get it
from http://koji.fedoraproject.org/koji/buildinfo?buildID=53887
That's what I did and it worked.

Comment 8 Jan ONDREJ 2008-06-29 08:05:18 UTC
I can't see an update request in bodhi. Why do you think, it gets to the mirrors?

I have no commit access to tk, so I can't request it.


Comment 9 D. Hugh Redelmeier 2008-06-29 20:14:12 UTC
I currently have tcl-8.5.1-4.fc9.x86_64 installed.

update viewer is offering me tcl-1:8.5.2.2-2.fc9 (x86_64) (from updates
repository) to replace tcl-1:8.5.1-4.fc9 (x86_64).

The one I see in koji has a lower version (tk-8.5.2-1.fc9) so that cannot be the
fix.

Comment #6 suggests that there is still a problem with tcl-8.5.2-2.  Is
Jonathan's problem only due to the previous problematic update (see #1) or would
it happen even if one hadn't done that update?

Right now, I'm telling the update viewer to NOT install the update.  I would
love to know when updating becomes safe.

Comment 10 D. Hugh Redelmeier 2008-06-29 20:17:20 UTC
Re #9: oops, I see that I was reading "tk" as "tcl".  So the Koji version (of
tk) might well be a fix.

My system has currently has tk-8.5.1-4.fc9.x86_64


Comment 11 Jonathan Ryshpan 2008-06-29 22:20:38 UTC
(In reply to comment #10)
> Re #9: oops, I see that I was reading "tk" as "tcl".  So the Koji version (of
> tk) might well be a fix.
> 
> My system has currently has tk-8.5.1-4.fc9.x86_64

Yup.  You've got it.  I have installed the latest tk from Koji, and it is a fix.


Comment 12 Braden McDaniel 2008-06-30 00:32:19 UTC
Is this bug the cause of this?

# rpm -q --whatrequires tcl.i386
no package requires tcl.i386
# rpm -e tcl.i386
error: Failed dependencies:
	tcl = 1:8.5.1 is needed by (installed) tk-8.5.1-4.fc9.x86_64


Comment 13 Kevin J. Cummings 2008-06-30 00:41:47 UTC
I just updated from a mirror:  tk-8.5.2-1.fc9.x86_64  and it now works.


Comment 14 Marcela Mašláňová 2008-06-30 07:20:18 UTC
*** Bug 453268 has been marked as a duplicate of this bug. ***

Comment 15 Marcela Mašláňová 2008-06-30 07:21:54 UTC
I'm sorry for the mess.
Thanks to lkundrak for creating the tk update.

Comment 16 Przemek Klosowski 2008-06-30 19:01:25 UTC
*** Bug 453258 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.