Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453225 - it crashes firstboot in reconfig mode
Summary: it crashes firstboot in reconfig mode
Keywords:
Status: CLOSED DUPLICATE of bug 461367
Alias: None
Product: Fedora
Classification: Fedora
Component: system-config-keyboard
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 21:33 UTC by Muayyad Alsadi
Modified: 2008-10-27 09:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-27 09:10:57 UTC


Attachments (Terms of Use)
patch -p1 (deleted)
2008-06-27 21:33 UTC, Muayyad Alsadi
no flags Details | Diff

Description Muayyad Alsadi 2008-06-27 21:33:10 UTC
Description of problem:
if someone asked firstboot to run in reconfig mode
it will call system-config-keyboard and it will crash
because kbd is used instead of self.kbd in python code

Version-Release number of selected component (if applicable):
1.2.15-2

How reproducible:
always

Steps to Reproduce:
1. chkconfig --level 5 firstboot on
2. rm /etc/sysconfig/firstboot
3. reboot and pass reconfig to grub

Actual results:
crash with NoneType object has no attribute 'beenset'

Expected results:
no error

Additional info:
patch included

Comment 1 Muayyad Alsadi 2008-06-27 21:33:10 UTC
Created attachment 310484 [details]
patch -p1

Comment 2 Lubomir Rintel 2008-10-27 09:10:57 UTC

*** This bug has been marked as a duplicate of bug 461367 ***


Note You need to log in before you can comment on or make changes to this bug.