Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453217 - packagekit failed to fetch category list
Summary: packagekit failed to fetch category list
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 10
Hardware: i686
OS: Linux
low
medium
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 450781 458534 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 20:44 UTC by hal
Modified: 2014-10-13 15:14 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-08 12:59:35 UTC


Attachments (Terms of Use)
selinux alert log triggered during update (deleted)
2008-07-01 21:56 UTC, hal
no flags Details

Description hal 2008-06-27 20:44:41 UTC
Description of problem: Can't get filelist for category


Version-Release number of selected component (if applicable): gpk-application 0.2.3.


How reproducible: Tried it twice - same problem both times


Steps to Reproduce:
1. Run add/remove software
2. Click on a category in the left panel (tried Programming and Office categories)
3.
  
Actual results: Some network traffic, then a dialog box saying "the group list
was invalid.  The group list could not be loaded.  Refreshing your cache might
help, although this is normally a software source error".  Clicking the more
details triangle shows the message "comps categories could not be loaded".

There is also a selinux alert and clicking that shows the message "SELinux is
preventing the gdm-session-wor from using potentially mislabeled files
(./.xsession-errors)."  No idea if this is related, but since the only thing
I've done since logging on was trying to run packagekit, maybe it is.


Expected results: List of available software displayed.


Additional info: This is a fresh installation from the fedora 9 x386 live CD
done yesterday.  I let software updates run after the install, rebooted, then
added rawhide to the list of software sources and let the updater run again, and
rebooted before running packagekit.

Comment 1 hal 2008-07-01 21:56:38 UTC
Created attachment 310730 [details]
selinux alert log triggered during update

Comment 2 hal 2008-07-01 22:04:49 UTC
I filled in several comments before, but when I attached a file to the bug
report, they were lost.  Briefly:

I reran the package update yesterday and this time was able to view packages. 
But the category I tried, programming, took at least 5 minutes to load on the
old machine I'm using for testing, and when I accidentally switched to another
category by pressing page down, it took the same excessive time to redisplay the
list.  (It would be nice if page up and page down worked in the software list
for browsing, but they don't seem to.)

The good news is that the interface makes it easy enough to select multiple
files for installation.  Except that the performance is horrible on an older
(1GHz) machine.  Takes 20 sec. to a minute each time a package selection box is
clicked.  This is with a fast, direct internet connection.

I left it running overnight and killed it 18 hours later while it was still
trying to do something.  It didn't succeed in installing anything, but
apparently did trigger some selinux alerts.  A log file is attached.

Please test this on some older machines ~1GHz machines before releasing it. 
It's too slow to be used now, but needs to work on machines like that which do
run fedora ok once it's installed.  Thanks.

Comment 3 Richard Hughes 2008-07-04 09:52:27 UTC
*** Bug 450781 has been marked as a duplicate of this bug. ***

Comment 4 Richard Hughes 2008-07-04 09:53:46 UTC
What's the output of rpm -qa | grep yum

Thanks.


Comment 5 hal 2008-07-04 17:17:01 UTC
Alas, I reformatted that machine and installed fedora 9 from the full CD set a day ago to see if I could 
make some progress.  Would this output still be useful?

(FWIW, packagekit is still slow to display category or package information, but it's the standard fedora 9 
one now, not the rawhide version.)

Comment 6 Richard Hughes 2008-08-18 08:48:50 UTC
*** Bug 458534 has been marked as a duplicate of this bug. ***

Comment 7 Clyde E. Kunkel 2008-09-04 20:14:34 UTC
$ rpm -qa | grep yum
yum-utils-1.1.16-1.fc10.noarch
yum-packagekit-0.3.1-3.fc10.i386
yum-metadata-parser-1.1.2-8.fc9.i386
yum-3.2.19-3.fc10.noarch

Fails for me also in i386 rawhide.  Here is what I get from cli:

$ gpk-application

(gpk-application:28649): Gtk-CRITICAL **: gtk_label_set_label: assertion `str != NULL' failed

(gpk-application:28649): Gtk-WARNING **: could not load image: Icon 'search' not present in theme


(gpk-application:28649): Gtk-WARNING **: could not load image: Icon 'search' not present in theme


(gpk-application:28649): Gtk-CRITICAL **: gtk_label_set_label: assertion `str != NULL' failed

(gpk-application:28649): Gtk-CRITICAL **: gtk_label_set_label: assertion `str != NULL' failed

(gpk-application:28649): Gtk-CRITICAL **: gtk_label_set_label: assertion `str != NULL' failed

(gpk-application:28649): Gtk-CRITICAL **: gtk_label_set_label: assertion `str != NULL' failed

Comment 8 Richard Hughes 2008-10-09 16:38:20 UTC
hal, have you tried PackaegKit in rawhide? It's substantially quicker at most operations. Some are quicker by an order of magnitude.

Comment 9 Fedora Update System 2008-11-11 16:25:02 UTC
PackageKit-0.3.10-1.fc9,gnome-packagekit-0.3.10-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/PackageKit-0.3.10-1.fc9,gnome-packagekit-0.3.10-1.fc9

Comment 10 Fedora Update System 2008-11-12 02:56:42 UTC
PackageKit-0.3.10-1.fc9, gnome-packagekit-0.3.10-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit gnome-packagekit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9573

Comment 11 Fedora Update System 2008-11-21 11:01:07 UTC
PackageKit-0.3.10-2.fc9, gnome-packagekit-0.3.10-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit gnome-packagekit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9573

Comment 12 Bug Zapper 2008-11-26 02:28:44 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 13 Fedora Update System 2008-12-08 12:59:18 UTC
PackageKit-0.3.10-2.fc9, gnome-packagekit-0.3.10-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 hal 2014-10-13 15:14:09 UTC
Something is broken with the bug tracking system.  I am still getting requests for more information even though this has been long closed out.  Please fix it:

The following is a list of requests people have made of you, which have been
outstanding more than 7 days. To avoid disappointing others, please deal with
them as quickly as possible.

needinfo
--------

 Bug 453217: packagekit failed to fetch category list (2184 days old)
   https://bugzilla.redhat.com/show_bug.cgi?id=453217


Note You need to log in before you can comment on or make changes to this bug.