Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453197 - Try to play test sound: error is 'no element gconfaudiosink'
Summary: Try to play test sound: error is 'no element gconfaudiosink'
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: pulseaudio
Version: rawhide
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: Lennart Poettering
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 19:14 UTC by Richard W.M. Jones
Modified: 2008-09-09 20:05 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-09 20:03:19 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2008-06-27 19:14:19 UTC
This is a Lenovo Thinkpad x60s laptop running Rawhide.

When I try to play the test sound in gnome, I get the error dialog:

audiotestsrc wave=sine freq=512 !
audioconvert ! audioresample !
gconfaudiosink: no element "gconfaudiosink"

There is no sound from any programs, although I can get something
if I pipe stuff into /dev/audio or /dev/dsp.

I have every gstreamer-* RPM installed.

The soundcard is:

cat /proc/asound/pcm 
00-01: AD198x Digital : AD198x Digital : playback 1
00-00: AD198x Analog : AD198x Analog : playback 1 : capture 1

but I'm pretty sure this is NOT a hardware problem (as I say,
I can pipe stuff into /dev/audio just fine).

Sound really should be easier ...

Comment 1 Richard W.M. Jones 2008-06-27 19:33:46 UTC
[I always forget to search closed Bugzillas, since the default
is only to search open ones ...  Anyway, after searching closed
ones ...]

I found that killing pulseaudio and restarting it (as my user,
not root), means that the test sounds work.

I haven't yet found out how to get sounds working in flash player
or totem yet, so that's what I'm trying now.

Comment 2 Richard W.M. Jones 2008-06-27 19:48:29 UTC
OK, totem is now working (after also restarting it).

Note I'm still having to kill and restart pulseaudio, so this is
definitely a bug.

Comment 3 Matthias Clasen 2008-08-26 04:00:56 UTC
Are you still seeing these problems ? 
PA works fine for me, no killing necessary...

Comment 4 Lennart Poettering 2008-09-09 20:03:19 UTC
I am closing this bug now since the problems are gone.

Should this problem still be reproducible, please set "log-level=debug", log out and in again, and reopen this bug and attach pa's syslog output.

Comment 5 Lennart Poettering 2008-09-09 20:05:56 UTC
log-level=debug is to be set in /etc/pulse/default.pa, btw.


Note You need to log in before you can comment on or make changes to this bug.