Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453181 - gthumb folder/catalog browser no longer works
Summary: gthumb folder/catalog browser no longer works
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gthumb
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 18:24 UTC by Jonathan Corbet
Modified: 2008-08-06 18:05 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-06 18:05:08 UTC


Attachments (Terms of Use)
g_logv backtraces from gdb (deleted)
2008-07-11 19:15 UTC, Jonathan Corbet
no flags Details

Description Jonathan Corbet 2008-06-27 18:24:07 UTC
Description of problem:

gthumb-2.10.8-3.fc10.x86_64 can display and manipulate an individual image as
always.  Whenever the folder or catalog views are brought up, though, it shows
only "no image."

Version-Release number of selected component (if applicable):

2.10.8-3.fc10

How reproducible:

Infinitely.

Steps to Reproduce:
1. Type "gthumb ." in a directory full of images
2. Wonder where your images went
3. 
  
Actual results:

"No image"

Expected results:

Image thumbnails.

Additional info:

Lots of messages like:
(gthumb:25889): Gtk-CRITICAL **: gtk_icon_info_get_filename: assertion
`icon_info != NULL' failed

(gthumb:25889): Gtk-CRITICAL **: gtk_icon_info_free: assertion `icon_info !=
NULL' failed

(gthumb:25889): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT
(object)' failed

Comment 1 John Poelstra 2008-06-27 19:11:32 UTC
triaged

Comment 2 Matthias Clasen 2008-07-08 16:22:57 UTC
Works here in current rawhide. Are you still seeing this ?

Comment 3 Jonathan Corbet 2008-07-08 23:58:30 UTC
I just brought my system up to today's rawhide (modulo mono dependency issues)
and checked; yes, the problem still happens.  I can view individual images in
gthumb, but no directories or catalogs.  I still get lots of GTK and Glib
"CRITICAL" messages.

Comment 4 Saurabh Bathe 2008-07-09 07:51:13 UTC
I am also seeing the same behaviour, however on i386.
$ rpm -q gthumb
gthumb-2.10.8-3.fc10.i386

I also do not get any of the gtk messages (I however remeber getting them
earlier when gthumb used to work.


Comment 5 Matthias Clasen 2008-07-10 04:35:07 UTC
hmm, what gtk versions do you have installed ?
Is a11y turned on ?


Comment 6 Jonathan Corbet 2008-07-11 15:48:35 UTC
I just pulled up to current rawhide:

gtk2-2.13.4-2.fc10.x86_64

I had "assistive technologies" turned off - is that what you mean?  I turned it
back on and restarted, but that didn't change anything.

Comment 7 Matthias Clasen 2008-07-11 18:27:36 UTC
Still can't reproduce. 

If you can run it in gdb, put a break on g_logv and show me the stacktrace from
when the warnings happen, then I could make a wild guess as to what the problem
might be.

Comment 8 Jonathan Corbet 2008-07-11 19:15:38 UTC
Created attachment 311612 [details]
g_logv backtraces from gdb

I got two basic traces, both of which are in the attachment.

Comment 9 Matthias Clasen 2008-07-19 01:16:43 UTC
I still can't reproduce, but I have tried to fix it anyway.
Please try 2.10.8-4.fc10

Comment 10 Jonathan Corbet 2008-07-20 00:47:35 UTC
OK, tried 2.10.8-4.fc10, no joy.  Lots of warnings, no folder or catalog view.

Comment 11 Jonathan Corbet 2008-07-20 01:39:09 UTC
FWIW, I've just stumbled across another surprise which may or may not be
related.  Running gthumb on a single .jpg file, I did some edits, then tried to
save the result.  I get a little "do not enter" dialog box saying "Image type
not supported: application/octet-stream".  Gthumb seems to be all thumbs for me
anymore...

Comment 12 Jonathan Corbet 2008-08-06 17:26:00 UTC
FYI: I decided to give this a random try after today's Rawhide update.  It would appear that, with gthumb-2.10.9-1.fc10.x86_64, the problem has gone away.  Actually, both problems (the image saving problem too) are gone.  That makes me happier.

Comment 13 Behdad Esfahbod 2008-08-06 18:05:08 UTC
Thanks Jon.


Note You need to log in before you can comment on or make changes to this bug.