Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453167 - Kickstart fails with pre-defined disk partitions
Summary: Kickstart fails with pre-defined disk partitions
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pyparted
Version: 5.1
Hardware: x86_64
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: David Cantrell
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 17:03 UTC by Cris Rhea
Modified: 2008-11-11 22:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-11-11 22:34:24 UTC
Target Upstream Version:


Attachments (Terms of Use)
Sample, simplified Kickstart file to demonstrate issue. (deleted)
2008-06-27 17:03 UTC, Cris Rhea
no flags Details

Description Cris Rhea 2008-06-27 17:03:21 UTC
Description of problem:

Using a kickstart file where the disk is pre-partitioned (in the %pre section)
fails with the error:

Error informing the kernel about modifications to partition /dev/sda5 -- Device
or resource busy.

Version-Release number of selected component (if applicable):
No clue. I would have put this in "Kickstart", but it's not listed in the
drop-down list. If pyparted is not the correct component, please let me know
where to move this.


How reproducible:

Every time.

Steps to Reproduce:
1. Use sample attached Kickstart file to attempt to load system. 
   Net boot from CD or use PXEboot (whatever convenient).

2. System will fail and display error message.
  
Actual results:

Kickstart install fails with above error. This has worked for years
(since at least RH7). Started failing between RHEL/CentOS 4.4 and 4.5.

The %pre section does work as expected (disk is physically partitioned correctly).

The blockdev and partprobe commands were added based on suggestions-- they were
never required previously.

Expected results:

Kickstart puts specified file systems on existing partitions.

Additional info:

Comment 1 Cris Rhea 2008-06-27 17:03:21 UTC
Created attachment 310461 [details]
Sample, simplified Kickstart file to demonstrate issue.

Comment 2 David Cantrell 2008-11-11 22:34:24 UTC
We're addressing issues like this one in Fedora first.  If this is an issue for your RHEL installation, please contact Red Hat technical support and have the issue escalated through our support channels.

Thanks.


Note You need to log in before you can comment on or make changes to this bug.