Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453143 - Anaconda Does not Renew/Drop DHCP IP Addresses
Summary: Anaconda Does not Renew/Drop DHCP IP Addresses
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 15:04 UTC by Matt Marshall
Modified: 2008-08-26 21:25 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-26 21:25:19 UTC


Attachments (Terms of Use)

Description Matt Marshall 2008-06-27 15:04:01 UTC
Description of problem:
During install of Centos, system will request dhcp address. If the dhcp lease
expires the address is not dropped, nor renewed. This can cause duplicate ip's
to be on the same network as the dhcp server is no longer aware that the initial
lease is still active.

Version-Release number of selected component (if applicable):


How reproducible: Consistent


Steps to Reproduce:
1. Start Network install
2. After getting DHCP address, leave system
3. When DHCP lease is supposed to expire check IP of system, and then check
lease table on DHCP server
  
Actual results:
The ip address is not shown as an active lease in the DHCP server anymore,
however the system will continue to retain that ip address.

Expected results:
The system should either drop the lease after the expiration, or renew the lease
to prevent duplicate ip's from occurring on the network.

Additional info:

Comment 1 Chris Lumens 2008-08-26 21:25:19 UTC
This will be fixed in the next major release of RHEL.  However, due to the scope of the work involved with making this change, it is very unlikely to see a RHEL5 update release.  We are essentially reworking all the networking code to make better use of system components, and this bug is fixed by that rewrite.


Note You need to log in before you can comment on or make changes to this bug.