Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453123 - [REGRESSION] Wrong input confuses bash's arithmetic unit permanently
Summary: [REGRESSION] Wrong input confuses bash's arithmetic unit permanently
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: bash
Version: 5.2
Hardware: All
OS: Linux
high
urgent
Target Milestone: rc
: ---
Assignee: Roman Rakus
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 13:00 UTC by Enrico Scholz
Modified: 2014-01-13 00:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 21:10:10 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0116 normal SHIPPED_LIVE bash bug fix update 2009-01-20 16:04:47 UTC

Description Enrico Scholz 2008-06-27 13:00:24 UTC
Description of problem:

Bug #286861 affects RHEL 5.2 too:

Scripts like

-----
: $(( tmp=foo.a+0 )) 
i=0 ; : $(( ++i )) ; echo $i 
-----

return the expected '1' on RHEL 5.1, but '0' on RHEL 5.2.  Further arithmetic
operations will be ignored silently.


This breaks existing applications, which check e.g. for numeric input with this
method.


Version-Release number of selected component (if applicable):

bash-3.2-21.el5 (broken)
bash-3.1-16.1   (ok)


How reproducible:

100%

Comment 1 Roman Rakus 2008-06-27 14:10:02 UTC
Patch should be backported.

Comment 2 RHEL Product and Program Management 2008-06-27 14:24:35 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 9 errata-xmlrpc 2009-01-20 21:10:10 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0116.html


Note You need to log in before you can comment on or make changes to this bug.