Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453101 - winbind gives up but reports successful startup
Summary: winbind gives up but reports successful startup
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: samba
Version: 4.7
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Guenther Deschner
QA Contact: qe-baseos-daemons
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 10:13 UTC by Petr Šplíchal
Modified: 2016-06-01 01:36 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2010-05-10 14:49:53 UTC


Attachments (Terms of Use)

Description Petr Šplíchal 2008-06-27 10:13:03 UTC
Description of problem:
winbind's init script reports successful startup despite the fact that winbind
gives up because of denied access to trust account secrets (happens for example
when /etc/samba/secrets.tdb has got a wrong selinux context, bug #452082).

Version-Release number of selected component (if applicable):
samba-3.0.28-0.el4.9

How reproducible:
Always

Steps to Reproduce:
change selinux context of /etc/samba/secrets.tdb
(or chmod ugo-rwx /etc/samba/secrets.tdb)
service winbind start
  
Actual results:
Starting Winbind services: [  OK  ]
# echo $?
0
# service winbind status
winbindd dead but subsys locked

Expected results:
Starting Winbind services: [FAILED]

Additional info:
# tail /var/log/samba/winbindd.log 
  Failed to open /etc/samba/secrets.tdb
  Could not initialize domain trust account secrets. Giving up

Comment 1 Dmitri Pal 2010-05-10 14:49:53 UTC
The related SELinux bug was solved but reporting the correct error in all situations is not possible.


Note You need to log in before you can comment on or make changes to this bug.