Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453093 - gcin gtk immodule should not be used for all locale
Summary: gcin gtk immodule should not be used for all locale
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcin
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Chung-Yen Chang
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 467095 (view as bug list)
Depends On:
Blocks: F10Target
TreeView+ depends on / blocked
 
Reported: 2008-06-27 08:38 UTC by Jens Petersen
Modified: 2008-10-24 20:03 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-24 20:03:19 UTC


Attachments (Terms of Use)

Description Jens Petersen 2008-06-27 08:38:20 UTC
Description of problem:
gcin's gtk immodule is enabled by default for all locale in
"/etc/gtk-2.0/*-redhat-linux-gnu/gtk-immodules".  I guess it
should only be enabled by default for at most "zh", probably
should be "" though since we do not want to run it on gdm, etc.

How reproducible:
every time

Steps to Reproduce:
1. install gcin
2. go to gdm login
  
Actual results:
see gcin running on gdm screen for non-Chinese locale.

Expected results:
gcin should not run by default.

Comment 1 Tony Fu 2008-09-10 03:08:34 UTC
requested by Jens Petersen (#27995)

Comment 2 Jens Petersen 2008-10-21 02:02:48 UTC
*** Bug 467095 has been marked as a duplicate of this bug. ***

Comment 3 Jens Petersen 2008-10-21 02:07:11 UTC
Candyz, could you please fix this for F10?

gcin should not be enabled for all locale and should not run on gdm.

im-chooser is the only correct way to enable input methods in Fedora.

Comment 4 Jens Petersen 2008-10-21 03:42:59 UTC
Should be fixed in gcin-1.4.2-4.fc10.

Comment 5 Bruno Wolff III 2008-10-21 16:32:25 UTC
I am no longer seeing the problem.


Note You need to log in before you can comment on or make changes to this bug.