Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453090 - registering system with incorrect password gives misleading error message
Summary: registering system with incorrect password gives misleading error message
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration
Version: 530
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Clifford Perry
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: 468864
TreeView+ depends on / blocked
 
Reported: 2008-06-27 07:54 UTC by Jan Hutař
Modified: 2014-05-09 10:39 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-09 10:39:04 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Jan Hutař 2008-06-27 07:54:37 UTC
Description of problem:
When I try to register a system with a correct username and an incorrect 
password, I get an error message, which implies that rhn_register is able to 
create a new account on the RHN server.


Version-Release number of selected component (if applicable):
up2date-4.7.1-17.el4


How reproducible:
always


Steps to Reproduce:
1. rhn_register --nox | rhn_register | rhnreg_ks


Actual results:
┌─────────────────┤ Error ├─────────────────┐
│                                           │
│ The server indicated an error:            │
│                                           │
│ Error Class Code: 3                       │
│ Error Class Info: This login is already   │
│ taken, or the password is incorrect.      │
│ Explanation:                              │
│      An error has occurred while          │
│ processing your request. If this problem  │
│      persists please enter a bug report   │
│ at bugzilla.redhat.com.                   │
│      If you choose to submit the bug      │
│ report, please be sure to include         │
│      details of what you were trying to   │
│ do when this error occurred and           │
│      details on how to reproduce this     │
│ problem.                                  │


Expected results:
┌─────────────────┤ Error ├─────────────────┐
│                                           │
│ The server indicated an error:            │
│                                           │
│ Error Class Code: 3                       │
│ Error Class Info: The login or            │
│     the password is incorrect.            │
│ Explanation:                              │
│     Please ensure you are using correct   │
│     and existing login/password ...       │


Additional info:
Creating of the RHN accounts through the client tools was disabled:
Bug 433492: hosted changes for user creation removal from registration
Bug 430151: remove account creation capability from rhn_register GUI
Bug 430153: remove account creation capability from rhn_register TUI

Comment 5 Pradeep Kilambi 2008-11-05 21:09:07 UTC
*** Bug 469719 has been marked as a duplicate of this bug. ***

Comment 6 Pradeep Kilambi 2008-11-05 21:10:27 UTC
*** Bug 469694 has been marked as a duplicate of this bug. ***

Comment 13 Clifford Perry 2014-05-09 10:39:04 UTC
We have not addressed this specific bug in over 5 years years. This does not seem to have an active customer case with the bug report either. Closing out as wontfix to clear from backlog. 

Please re-open if you disagree and wish further review.

Cliff


Note You need to log in before you can comment on or make changes to this bug.