Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453087 - pstree(1) memory leak [NEEDINFO]
Summary: pstree(1) memory leak
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: psmisc
Version: 5.1
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Jaromír Cápík
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-27 07:31 UTC by masanari iida
Modified: 2014-06-02 13:15 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-06-02 13:15:45 UTC
pm-rhel: needinfo? (masanari_iida)


Attachments (Terms of Use)

Description masanari iida 2008-06-27 07:31:45 UTC
Description of problem:
pstree(1) seemed to be forget to free blocks,
according to valgrind.

Version-Release number of selected component (if applicable):
psmisc-22.2-5

How reproducible:
always

Steps to Reproduce:
1. Install valgrind from Fedora9 
2. Run valgrind --tool=memcheck --leak-check=full pstree

  
Actual results:

==16399==
==16399== ERROR SUMMARY: 484 errors from 3 contexts (suppressed: 16 from 1)
==16399== malloc/free: in use at exit: 9,272 bytes in 289 blocks.
==16399== malloc/free: 971 allocs, 682 frees, 574,963 bytes allocated.
==16399== For counts of detected errors, rerun with: -v
==16399== searching for pointers to 289 not-freed blocks.
==16399== checked 151,168 bytes.
==16399==
==16399==
==16399== 160 (64 direct, 96 indirect) bytes in 8 blocks are definitely lost in
loss record 1 of 4
==16399==    at 0x40054E5: malloc (vg_replace_malloc.c:149)
==16399==    by 0x8049310: (within /usr/bin/pstree)
==16399==    by 0x804A995: (within /usr/bin/pstree)
==16399==    by 0x35ADEB: (below main) (in /lib/libc-2.5.so)
==16399==
==16399== LEAK SUMMARY:
==16399==    definitely lost: 64 bytes in 8 blocks.    <==
==16399==    indirectly lost: 96 bytes in 12 blocks.   <==
==16399==      possibly lost: 0 bytes in 0 blocks.
==16399==    still reachable: 9,112 bytes in 269 blocks.
==16399==         suppressed: 0 bytes in 0 blocks.
==16399== Reachable blocks (those to which a pointer was found) are not shown.
==16399== To see them, rerun with: --leak-check=full --show-reachable=yes



Expected results:
No memory leak

Additional info:

Comment 1 Tomas Smetana 2008-06-27 08:57:13 UTC
I found actually two leaks: one is quite easy to fix.  I'll examine the other.

Comment 2 RHEL Product and Program Management 2009-03-26 16:51:24 UTC
This request was evaluated by Red Hat Product Management for
inclusion, but this component is not scheduled to be updated in
the current Red Hat Enterprise Linux release. If you would like
this request to be reviewed for the next minor release, ask your
support representative to set the next rhel-x.y flag to "?".

Comment 4 RHEL Product and Program Management 2010-08-09 18:26:45 UTC
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated in the
current release, Red Hat is unfortunately unable to address this
request at this time. Red Hat invites you to ask your support
representative to propose this request, if appropriate and relevant,
in the next release of Red Hat Enterprise Linux.

Comment 5 RHEL Product and Program Management 2014-03-07 13:41:27 UTC
This bug/component is not included in scope for RHEL-5.11.0 which is the last RHEL5 minor release. This Bugzilla will soon be CLOSED as WONTFIX (at the end of RHEL5.11 development phase (Apr 22, 2014)). Please contact your account manager or support representative in case you need to escalate this bug.

Comment 6 RHEL Product and Program Management 2014-06-02 13:15:45 UTC
Thank you for submitting this request for inclusion in Red Hat Enterprise Linux 5. We've carefully evaluated the request, but are unable to include it in RHEL5 stream. If the issue is critical for your business, please provide additional business justification through the appropriate support channels (https://access.redhat.com/site/support).


Note You need to log in before you can comment on or make changes to this bug.