Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453063 - startkde fails to find lnusertemp (kstandarddirs problem)
Summary: startkde fails to find lnusertemp (kstandarddirs problem)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase-workspace
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: KDE41
TreeView+ depends on / blocked
 
Reported: 2008-06-27 01:04 UTC by Rex Dieter
Modified: 2008-06-27 02:34 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-27 02:34:39 UTC


Attachments (Terms of Use)

Description Rex Dieter 2008-06-27 01:04:48 UTC
startkde contains references to lnusertemp, and

$ kde4-config --path exe --locate lnusertemp
/usr/bin/lnusertemp

$ rpm -q -f /usr/bin/lnusertemp
kdelibs3-3.5.9-15.fc9.x86_64

I moved that out of the way, and the kde4-config call finds nothing


$ mv  /usr/bin/lnusertemp  /usr/bin/lnusertemp.kde3
$ kde4-config --path exe --locate lnusertemp
<blank>


Net result is that kde4 session fails to start if kdelibs3 isn't installed.

Comment 1 Rex Dieter 2008-06-27 01:08:58 UTC
fwiw,
$ kde4-config --path exe 
/home/rdieter1/.kde/libexec/kde4/:/home/rdieter1/.kde/bin/:/usr/bin/

no /usr/libexec ?

Comment 2 Kevin Kofler 2008-06-27 01:16:27 UTC
With kdelibs-4.0.5-2.fc9, I get:
/home/kevin/.kde/libexec/kde4/:/home/kevin/.kde/bin/:/usr/bin/:/usr/libexec/kde4/
Likewise kdelibs4-4.0.5-2.fc8. So this sounds like a regression in our KDE 4.1 
packages. (Rex is using 4.0.83.)

Still the order is bad, /usr/libexec/kde4 should come first, this sounds like 
fallout from the kstandarddirs patch.

Comment 3 Kevin Kofler 2008-06-27 01:25:15 UTC
The ordering issue on F9 can probably be fixed by changing:
if (strcmp("config", type))
to:
if (strcmp("config", type) && strcmp("exe", type))
and:
if (!strcmp("config", type))
to:
if (!strcmp("config", type) || !strcmp("exe", type))
in the kstandarddirs patch.

The KDE 4.1 issue sounds different.

Comment 4 Kevin Kofler 2008-06-27 01:58:47 UTC
Different, but related, it turns out this upstream kstandarddirs change is to 
blame:
http://websvn.kde.org/trunk/KDE/kdelibs/kdecore/kernel/kstandarddirs.cpp?r1=819551&r2=819560

F9 build: http://koji.fedoraproject.org/koji/taskinfo?taskID=682824
Rawhide build: http://koji.fedoraproject.org/koji/taskinfo?taskID=682835

Comment 5 Kevin Kofler 2008-06-27 02:31:10 UTC
I can confirm that the ordering issue is fixed in kdelibs-4.0.5-4.fc9. Rex 
confirms 4.0.83-3.fc10 is good as well (/usr/libexec/kde4 is listed and in the 
correct order).

F8 kdelibs4 build here: 
http://koji.fedoraproject.org/koji/taskinfo?taskID=682865


Note You need to log in before you can comment on or make changes to this bug.