Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453057 - revisor fails to create live cd, and does not handle a certain exception
Summary: revisor fails to create live cd, and does not handle a certain exception
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: revisor
Version: 9
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeroen van Meeuwen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-26 23:35 UTC by Thomas Vander Stichele
Modified: 2008-07-01 05:30 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 16:37:05 UTC


Attachments (Terms of Use)

Description Thomas Vander Stichele 2008-06-26 23:35:27 UTC
Description of problem:

I'm trying to create a Live CD.  After selecting everything, Revisor is building
the Installation Images.

It's at Cleaning Up Build Environment - Pending.

Task Progress is filled completely,
Total Progress about quarter way through.

The console is showing this python backtrace:

Traceback (most recent call last):
  File "/usr/lib/python2.5/site-packages/revisor/modgui/lm_usercustomize.py",
line 135, in button_forward_clicked
    self.gui.next()
  File "/usr/lib/python2.5/site-packages/revisor/modgui/__init__.py", line 447,
in next
    self.default[self.current]['disp'](self)
  File "/usr/lib/python2.5/site-packages/revisor/modgui/__init__.py", line 315,
in displayBuildMedia
    self.BuildMedia.start()
  File "/usr/lib/python2.5/site-packages/revisor/modgui/build_media.py", line
65, in start
    self.base.lift_off()
  File "/usr/lib/python2.5/site-packages/revisor/base.py", line 1078, in lift_off
    self.buildInstallationMedia()
  File "/usr/lib/python2.5/site-packages/revisor/base.py", line 1357, in
buildInstallationMedia
    mypungi.doBuildinstall(callback=pungicallback)
  File "/usr/lib/python2.5/site-packages/revisor/pungi.py", line 309, in
doBuildinstall
    self.base.run_command(buildinstall, callback=callback)
  File "/usr/lib/python2.5/site-packages/revisor/base.py", line 1825, in run_command
    p1 = subprocess.Popen(command, cwd=rundir, stdout=output, stderr=error,
shell=inshell, env=env, preexec_fn = preexec_fn)
  File "/usr/lib/python2.5/subprocess.py", line 593, in __init__
    errread, errwrite)
  File "/usr/lib/python2.5/subprocess.py", line 1079, in _execute_child
    raise child_exception
OSError: [Errno 13] Permission denied

But from that I can't tell what it was actually trying to do (beside executing
something)

Version-Release number of selected component (if applicable):
2.1.1-4.fc9

How reproducible:

always

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Thomas Vander Stichele 2008-06-26 23:51:54 UTC
I added a print to see what buildinstall ends up being:
THOMAS: buildinstall ['/usr/share/revisor/scripts/F9-buildinstall', '--debug',
'--product', 'Fedora', '--variant', 'f9f-i386', '--version', '9', '--release',
'Fedora 9', '/var/tmp/revisor-pungi/9/f9f-i386/i386/os',
'http://download.fedora.redhat.com.amantes/pub/fedora/linux/releases/9/Fedora/i386/os/']

of course, this script in /usr/share/revisor/scripts is not executable, and
neither are its friends:

[thomas@ana ~]$ ls /usr/share/revisor/scripts/ -l
total 20
-rw-r--r-- 1 root root 3856 2008-05-23 00:15 F7-buildinstall
-rw-r--r-- 1 root root 3679 2008-05-23 00:15 F8-buildinstall
-rw-r--r-- 1 root root 4528 2008-05-23 00:15 F9-buildinstall
-rw-r--r-- 1 root root 3497 2008-05-23 00:15 RHEL5-buildinstall

No wonder it doesn't work :)

Comment 2 John (J5) Palmieri 2008-06-27 15:01:13 UTC
looks like a packaging issue but I can't spot it.  The scripts are executable in
the tarball.

Comment 3 John (J5) Palmieri 2008-06-27 15:12:09 UTC
jumped the gun there, something is wrong with the makefile when it installs to
the buildroot

Comment 4 John (J5) Palmieri 2008-06-27 15:59:16 UTC
Submitted a patch upstream that fixes this issue by moving the scripts to
/usr/lib/revisor/scripts 

https://fedorahosted.org/revisor/ticket/338

Please look at the specfile changes in the patch and add those to the next
build.  I would hold off on the build however as there are a number of other
bugs being looked at.

Comment 5 Jeroen van Meeuwen 2008-06-30 16:37:05 UTC
Fixed in GIT, ticket #338 closed upstream (thanks J5)

Comment 6 Fedora Update System 2008-06-30 18:04:36 UTC
revisor-2.1.1-5.fc9 has been submitted as an update for Fedora 9

Comment 7 Fedora Update System 2008-07-01 05:30:53 UTC
revisor-2.1.1-5.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.