Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453054 - 1.1.1-1.fc10 listens only on IPv6 interfaces
Summary: 1.1.1-1.fc10 listens only on IPv6 interfaces
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: dovecot
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Dan Horák
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-26 23:08 UTC by Kenneth Porter
Modified: 2008-06-27 17:36 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-27 07:51:33 UTC


Attachments (Terms of Use)

Description Kenneth Porter 2008-06-26 23:08:32 UTC
The SRPM patch dovecot-1.1-default-settings.patch changes the default interface
list from "*" to "[::]" which causes dovecot to listen only on all IPv6
interfaces instead of on all IPv4 interfaces. The comments in the configuration
file suggest using "*, [::]" to listen to both. What is the desired policy? I
was expecting at least IPv4 service to work without customization. (I'm
upgrading a CentOS 5 system.)

Comment 1 John Poelstra 2008-06-27 03:07:36 UTC
triaged

Comment 2 Dan Horák 2008-06-27 05:28:26 UTC
The default "listen" setting is consistent with this setting in the 1.0.x series
in F-9 and earlier. It used the "[::] listens in on all IPv6 intefaces, but may
 also listen on all IPV4 interfaces depending on the OS" clause. So now I need
to check what has changed, whether the listen code in dovecot 1.1 (vs, the
1.0.x) or newer glibc is the cause or ...

Comment 3 Dan Horák 2008-06-27 07:51:33 UTC
default settings are updated, koji build at
http://koji.fedoraproject.org/koji/buildinfo?buildID=53954

Comment 4 Kenneth Porter 2008-06-27 17:36:47 UTC
Dovecot changeset that resulted in the issue:

http://hg.dovecot.org/dovecot-1.1/rev/da971cec0395

Discussion thread on Dovecot mailing list:

http://dovecot.org/list/dovecot/2008-June/031733.html


Note You need to log in before you can comment on or make changes to this bug.