Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453035 - missing Requires for audacious-devel
Summary: missing Requires for audacious-devel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: audacious
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Ralf Ertzinger
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: 453026
TreeView+ depends on / blocked
 
Reported: 2008-06-26 19:27 UTC by Dominik 'Rathann' Mierzejewski
Modified: 2008-09-06 15:21 UTC (History)
0 users

Fixed In Version: audacious-1.5.1-3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-06 15:21:23 UTC


Attachments (Terms of Use)

Description Dominik 'Rathann' Mierzejewski 2008-06-26 19:27:48 UTC
Description of problem:
audacious-devel is missing BuildRequires: dbus-glib-devel.

Version-Release number of selected component (if applicable):
1.5.1-1.fc10

How reproducible:
Always

Steps to Reproduce:
1. install audacious-devel without dbus-{glib-,}devel
2. pkg-config --cflags audacious
  
Actual results:
$ pkg-config --cflags audacious
Package dbus-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `dbus-1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'dbus-1', required by 'Audacious', not found

After installing dbus-devel:
$ pkg-config --cflags audacious
Package dbus-glib-1 was not found in the pkg-config search path.
Perhaps you should add the directory containing `dbus-glib-1.pc'
to the PKG_CONFIG_PATH environment variable
Package 'dbus-glib-1', required by 'Audacious', not found

Expected results:
$ pkg-config --cflags audacious
-pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include
-I/usr/include/gtk-2.0 -I/usr/include/pango-1.0 -I/usr/include/cairo
-I/usr/include/libmowgli -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include
-I/usr/lib/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/freetype2  

Additional Information:
I haven't checked if that applies to F-9 as well.

Comment 1 John Poelstra 2008-06-27 03:06:41 UTC
triaged

Comment 2 Dominik 'Rathann' Mierzejewski 2008-08-29 21:41:12 UTC
(In reply to comment #0)
> Description of problem:
> audacious-devel is missing BuildRequires: dbus-glib-devel.

Hm. Now that I think back about it, I think I meant Requires:, not BuildRequires:.
Makes more sense that way. :)


Note You need to log in before you can comment on or make changes to this bug.