Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453028 - php-devel should Require autoconf, automake
Summary: php-devel should Require autoconf, automake
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: php
Version: 4.8
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Joe Orton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-26 19:16 UTC by Tim Jackson
Modified: 2009-05-18 20:33 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-18 20:33:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:1013 normal SHIPPED_LIVE php bug fix and enhancement update 2009-05-18 14:14:11 UTC

Description Tim Jackson 2008-06-26 19:16:22 UTC
Description of problem:
Running "phpize" (provided by php-devel) on a clean system (such as that
provided by mock) results in an error, because phpize utilises autoconf and automake

Version-Release number of selected component (if applicable):
php-devel-4.3.9-3.22.9

How reproducible:
Always

Steps to Reproduce:
1. Create a spec file which runs "phpize" against a PECL package
2. run it under mock
  
Actual results:
...
+ /usr/bin/phpize
/usr/bin/phpize: line 57: aclocal: command not found


Expected results:
No error

Additional info:

From the phpize script:

"aclocal || exit 1
autoconf || exit 1
autoheader || exit 1"

Newer versions of PHP (such as in recent Fedoras) get this right.

Comment 1 Joe Orton 2008-06-27 10:22:24 UTC
Thanks for the report.

Comment 2 RHEL Product and Program Management 2008-09-05 17:16:12 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 7 errata-xmlrpc 2009-05-18 20:33:05 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-1013.html


Note You need to log in before you can comment on or make changes to this bug.