Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 453025 - constant high CPU usage
Summary: constant high CPU usage
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: compiz
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-26 19:05 UTC by Colin Walters
Modified: 2018-04-11 06:53 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-22 10:45:40 UTC


Attachments (Terms of Use)

Description Colin Walters 2008-06-26 19:05:32 UTC
compiz-0.7.6-2.fc9.x86_64
kmod-nvidia-173.14.09-1.lvn9.x86_64
01:00.0 VGA compatible controller: nVidia Corporation GeForce Go 7900 GS (rev a1)

Compiz seems to be constantly using about 30% of a core.  strace reveals lots of:

 getpid()                                = 30362
 getpid()                                = 30362
 getpid()                                = 30362
 getpid()                                = 30362
...
 sched_yield()                           = 0
 sched_yield()                           = 0

Comment 1 John Poelstra 2008-06-27 03:06:12 UTC
Is it possible for Fedora to fix this bug considering the nvidia binary driver
is being used?

Comment 2 Matěj Cepl 2008-07-22 10:45:40 UTC
Thanks for the report. We are sorry that we cannot help you with your problem,
but we are not able to support binary-only drivers. If you would be able to
reproduce this issue using only open source software, please, reopen this bug
with the additional information, but in meantime I have no choice than to close
this bug as CANTFIX (because we really cannot fix it).

For users who are experiencing problems installing, configuring, or using the
unsupported 3rd party proprietary "nvidia" video driver, Nvidia provides
indirect customer support via an online web based support forum.  Nvidia
monitors these web forums for commonly reported problems and passes them on to
Nvidia engineers for investigation.  Once they've isolated a particular problem,
it is often fixed in a future video driver update.

The NVNews Nvidia Linux driver forum is located at:

    http://www.nvnews.net/vbulletin/forumdisplay.php?s=&forumid=14

Once you have reported this issue in the Nvidia web forums, others who may have
experienced the particular problem may be able to assist.  If there is a real
bug occuring, Nvidia will be able to determine this, and will likely resolve the
issue in a future driver update for the operating system releases that they
officially support.

While Red Hat does not support the proprietary nvidia driver, users requiring
technical support may also find the various X.Org, XFree86, and Red Hat mailing
lists helpful in finding assistance:

X.Org mailing lists:
    http://www.freedesktop.org/XOrg/XorgMailingLists

XFree86 mailing lists:
    http://www.xfree86.org/sos/lists.html

Red Hat mailing lists:
    https://listman.redhat.com/mailman/listinfo


Note You need to log in before you can comment on or make changes to this bug.