Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4530 - second processor idle
Summary: second processor idle
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel
Version: 6.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Cristian Gafton
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-15 04:52 UTC by gilmore
Modified: 2008-08-01 16:22 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:


Attachments (Terms of Use)

Description gilmore 1999-08-15 04:52:39 UTC
Hi,

We installed the SMP kernel from our RH6.0 distribution
onto A DP Pentium Pro system but it seems that only one
one processor is running user processes.

I put two shell loops into background via:

echo 'while : ; do : ; done' | sh &

and then waited for a few seconds and ran top:

21530 gilmore   17   0   804  804   680 R       0 40.6  0.3
  3:27 sh
20224 radha     20   4 92824  90M  1280 R N     0 38.3 36.0
794:13 casim_fast
21518 gilmore   15   0   804  804   680 R       0 28.8  0.3
 15:51 sh


/proc/cpuinfo reports:

processor	: 0
vendor_id	: GenuineIntel
cpu family	: 6
model		: 1
model name	: Pentium Pro
stepping	: 9
cpu MHz		: 199.434997
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
sep_bug		: no
f00f_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic
sep mtrr pge mca cmov
bogomips	: 199.07

processor	: 1
vendor_id	: GenuineIntel
cpu family	: 6
model		: 1
model name	: Pentium Pro
stepping	: 9
cpu MHz		: 199.434997
cache size	: 256 KB
fdiv_bug	: no
hlt_bug		: no
sep_bug		: no
f00f_bug	: no
fpu		: yes
fpu_exception	: yes
cpuid level	: 2
wp		: yes
flags		: fpu vme de pse tsc msr pae mce cx8 apic
sep mtrr pge mca cmov
bogomips	: 199.07

Any idea on what could be the cause?

Thanks,

Doug Gilmore
Equator Technologies

Comment 1 Cristian Gafton 1999-08-30 01:59:59 UTC
How can you tell from that that only one processor is being used? A
process can not run on more than one CPU at once; the kernel will
load-balance the CPUs though when new processes are created.


Note You need to log in before you can comment on or make changes to this bug.