Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452990 - iwl4965 doesn't work after hibernate; modprobe doesn't help
Summary: iwl4965 doesn't work after hibernate; modprobe doesn't help
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: John W. Linville
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-26 14:20 UTC by Andrew Overholt
Modified: 2008-12-11 19:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-11 19:32:24 UTC


Attachments (Terms of Use)

Description Andrew Overholt 2008-06-26 14:20:17 UTC
Description of problem:
I'm running x86_64 Fedora 9 on a Thinkpad x61.  I've hibernated a few times
since getting this laptop last week, and never really noticed this before, but
this morning when I turned it back on, it can no longer connect to the wireless
network.

Version-Release number of selected component (if applicable):
kernel-2.6.25.6-55.fc9.x86_64

How reproducible:
Not sure

Steps to Reproduce:
1. hibernate
2. wake up (connected to dock ... don't know if that matters)
3. modprobe -r iwl4965; modprobe iwl4965
  
Actual results:
No wireless device.  dmesg contains:

iwl4965: Tx 0 queue init failed
iwl4965: Unable to init nic

Expected results:
Wireless device works.

Additional info:

Comment 1 Andrew Overholt 2008-06-26 15:17:15 UTC
I don't know if this is related, but I just suspended (to memory) my laptop and
opened it while in the dock and it hung while getting a wireless network
connection.  I hard-restarted it and the same thing happened twice more.  I
rebooted into 2.6.25.4-30.fc9.x86_64 and it seems to be working fine.

Comment 2 John W. Linville 2008-06-26 15:28:58 UTC
Many have reported such hangs with -55.fc9.  Please try -57.fc9 or later:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=52456

Comment 3 John W. Linville 2008-07-31 14:59:57 UTC
Are you still experiencing this issue with current F9 kernels (e.g. -97 or 
later)?

Comment 4 Andrew Overholt 2008-07-31 16:04:03 UTC
I can't seem to hibernate with -97:  bug #457424.

Comment 5 John W. Linville 2008-12-11 18:52:38 UTC
Are you able to recreate this now?

Comment 6 Andrew Overholt 2008-12-11 19:32:24 UTC
Looks like it works with 2.6.27.5-117.fc10.x86_64.


Note You need to log in before you can comment on or make changes to this bug.