Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452984 - Packagekit desktop applet: "failed to update system" error
Summary: Packagekit desktop applet: "failed to update system" error
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: PackageKit
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-26 13:15 UTC by Steevithak
Modified: 2008-07-03 17:55 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-03 17:14:14 UTC


Attachments (Terms of Use)

Description Steevithak 2008-06-26 13:15:22 UTC
Description of problem: When the packagekit icon checks for updates and finds
them, it offers to update the system but always fails with the following cryptic
and meaningless (at least to an end user) error message: 

 Failed to update system
 The error was: org.freedesktop.packagekit.update-system auth_admin_keep_always

The same error is also generated if you click on the packagekit icon and select
"update system". 

A work around is to open a command prompt and type "yum update" which works
perfectly with no errors.

This error occurs 100% of the time on both my Inspiron 8600 laptop and on a VIA
Mini-ITX desktop system with Fedora 9.


Version-Release number of selected component (if applicable):

Packagekit Update Applet 0.1.12

How reproducible:

Fails 100% of the time

Steps to Reproduce:
1. Install Fedora
2. Wait for updates
3. ask package kit to install updates
4. watch it fail
  
Actual results: updates should be installed 

Expected results: no updates are installed and a cryptic error message is
display that provide no useful information to the end user about the cause of
the problem.


Additional info: The Fedora update icon worked perfectly on both the machines in
all previous versions of Fedora.

Comment 1 Richard Hughes 2008-06-26 14:35:08 UTC
Are you logging in as root?

Comment 2 Steevithak 2008-06-26 15:11:46 UTC
On the desktop, it gets the error if I'm logged in as a non-root user AND when I
log in as root. I only just installed Fedora on my laptop and have only logged
in as root so far. I'll create a non-root user and give that a try.

Comment 4 Steevithak 2008-07-02 17:36:01 UTC
After installing the latest Fedora 9 updates (manually using Yum), there's a
change in behavior on this bug. It seems to be half-fixed. I see different
results depending on whether I'm logged in as a normal user or as root:

1. Logged into Gnome as root: When I'm prompted to update the system, nothing
happens. There is no longer a "failed to update system" error message. The
update simply fails silently with no results.

2. Logged into Gnome as a non-root user: It now seems to work correctly. When
I'm prompted to update the system, it doesn't generate an error. Instead, it
correctly prompts me for the root password, then does the update. My only
complaint is that there is no confirmation that anything is happening once the
update starts - no progress meter, no "updating" dialog or anything like that.
But if you click the update icon in the toolbar again, it's possible to open a
progress meter. This is confusing but at least it works, so that's good news.

So, for me at least, this bug is now occurring only when I'm logged into the
Gnome desktop as root. 

Comment 5 Richard Hughes 2008-07-03 17:14:14 UTC
Please see http://www.packagekit.org/pk-faq.html#run-as-root

Comment 6 Steevithak 2008-07-03 17:55:34 UTC
Hmmm... okay, so as of Fedora 9, you can no longer update the system when logged
in as Root, by design? Then I at least think it's a bug that it doesn't say
that. How about a dialog that says "sorry, you have to log out, log in as
non-root, then give the root password anyway to update the system" :)  instead
of crashing when you try to do the update? 

Seriously, though, I don't think it's unreasonable to expect the system update
function to work for root. 


Note You need to log in before you can comment on or make changes to this bug.