Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452971 - mod_mono and xsp version mismatch
Summary: mod_mono and xsp version mismatch
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: xsp
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Paul F. Johnson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-26 11:15 UTC by Vilius Šumskas
Modified: 2008-12-14 12:16 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-14 12:16:25 UTC


Attachments (Terms of Use)

Description Vilius Šumskas 2008-06-26 11:15:34 UTC
Description of problem:
Because of mod_mono and xsp version mismatch all mono ASP applications doesn't 
load. Internal server error HTTP 500 is shown.

Version-Release number of selected component (if applicable):
xsp-1.2.1-1.fc7.i386

How reproducible:
Always.

Steps to Reproduce:
1. service httpd start with mod_mono loaded.
2. Load any mono ASP application into the browser.
  
Actual results:
Application doesn't run and quits with HTTP 500 internal server error.
Apache error log says:
mod_mono and xsp have different versions.
System.InvalidOperationException: mod_mono and xsp have different versions.
  at Mono.WebServer.ModMonoRequest.GetInitialData () [0x00000]
  at Mono.WebServer.ModMonoRequest..ctor (System.Net.Sockets.NetworkStream ns) 
[0x00000]
  at Mono.WebServer.RequestReader..ctor (System.Net.Sockets.NetworkStream ns) 
[0x00000]
  at Mono.WebServer.ModMonoWorker.InnerRun (System.Object state) [0x00000]
  at Mono.WebServer.ModMonoWorker.Run (System.Object state) [0x00000]
[Thu Jun 26 12:38:38 2008] [error] (104)Connection reset by peer: read_data 
failed
[Thu Jun 26 12:38:38 2008] [error] Command stream corrupted, last command was -1


Expected results:
Application should run, Apache httpd should not report any errors.

Comment 1 Paul F. Johnson 2008-10-20 12:23:43 UTC
1.9.1 for both XSP and mod_mono should be in f9 stable by now. Version 2 should hit f9-testing towards the end of this week.

Comment 2 Vilius Šumskas 2008-10-21 16:41:15 UTC
I still don't see 1.9.1 in F9 stable. But I see version 2 in F10-dev.


Note You need to log in before you can comment on or make changes to this bug.