Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452957 - [RHEL5] localtime() does not handle changes to /etc/locatime
Summary: [RHEL5] localtime() does not handle changes to /etc/locatime
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: glibc
Version: 5.2
Hardware: All
OS: Linux
high
medium
Target Milestone: rc
: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL: http://sources.redhat.com/bugzilla/sh...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-26 09:02 UTC by Subhendu Ghosh
Modified: 2018-10-20 02:36 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-03-04 09:03:34 UTC


Attachments (Terms of Use)
Fedora8 strace crond -n output (deleted)
2008-06-26 17:51 UTC, Subhendu Ghosh
no flags Details
RHEL5 strace crond -n output (deleted)
2008-06-26 17:52 UTC, Subhendu Ghosh
no flags Details

Description Subhendu Ghosh 2008-06-26 09:02:26 UTC
Description of problem:
localtime() cannot handle any changes made to /etc/localtime.

When invoked in a long running program (eg. cron) /etc/localtime is only stat()
at the first invocation of localtime() via tzset(). Subsequent calls to
localtime() do not use tzset() to check if /etc/localtime has changed.

Version-Release number of selected component (if applicable):
glibc-2.5-24

How reproducible:
strace crond -n

Steps to Reproduce:
1. 
2.
3.
  
Actual results:

/etc/localtime is only checked on the first invocation of localtime()

Expected results:

expect /etc/localtime to be checked for every invocation of localtime()

Additional info:

Bug seems to be fixed in upstream glibc and fedora 8 
glibc BZ 5186

Comment 1 Subhendu Ghosh 2008-06-26 17:51:58 UTC
Created attachment 310352 [details]
Fedora8 strace crond -n output

Comment 2 Subhendu Ghosh 2008-06-26 17:52:44 UTC
Created attachment 310353 [details]
RHEL5 strace crond -n output

Comment 4 Jakub Jelinek 2009-03-04 09:03:34 UTC
Will be fixed in RHEL6.


Note You need to log in before you can comment on or make changes to this bug.