Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452937 - Installing from DVD but prompted for Disc 1 after component selection
Summary: Installing from DVD but prompted for Disc 1 after component selection
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 9
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: http://forums.fedoraforum.org/showthr...
Whiteboard:
: 454321 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-26 02:58 UTC by Gavin Gunnigle
Modified: 2008-10-24 19:06 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-24 19:06:36 UTC


Attachments (Terms of Use)
anaconda.log (deleted)
2008-10-23 22:42 UTC, Will Woods
no flags Details
anaconda-ks.cfg (deleted)
2008-10-23 22:44 UTC, Will Woods
no flags Details

Description Gavin Gunnigle 2008-06-26 02:58:37 UTC
Description of problem:
When installing via the GUI from the Fedora 9 DVD and opting to include several
components to be downloaded and installed immediately, the installation process
says that it is connecting to download the packages. After a few minutes, I got
a prompt to insert Disc 1. I thought this was strange since I was using the DVD!
I tried to dowload the i386 Disc 1 CD, but that was not effective.

Version-Release number of selected component (if applicable):


How reproducible:
I only tried this once, and opted to try downloading the CDs instead of wasting
more time on the DVD. Several other people have experienced the exact same
problem (see thread here: http://forums.fedoraforum.org/showthread.php?t=191400)

Steps to Reproduce:
1. Start a new installation of the Fedora 9 OS from the DVD image
2. Use the GUI to install
3. Select many of the optional components, particularly those to do with
authoring, web hosting, web development, etc.
  
Actual results:


Expected results:


Additional info:

Comment 1 Chris Lumens 2008-06-26 12:53:34 UTC
Can you attach /tmp/anaconda.log to this bug report?

Did you enable the "Additional Fedora Software" repo on the first
package-related screen?  That's the only reason I can think of for it to be
downloading packages.

Comment 2 Gavin Gunnigle 2008-06-26 13:21:34 UTC
I will be happy to attach the requested log, but I have to go back and repeat
the steps with the DVD (which will have to wait until late tonight), and I also
will need instructions on how to actually save the log file - I'm afraid I'm
pretty much brand-new to Linux, and don't know how to access a log file without
the OS being functional. In addition, once I received the prompt to insert Disc
1 I seemed to be unable to back out of it, so unless there's some keyboard
shortcut or something then I will be stuck at that prompt.

To answer your other question, I believe I did opt for "Additional Fedora
Software". If that's the point at which you select additional optional
components to be installed during the OS installation, then that answer is
definitely a "yes."

Sorry I'm being vague - again, REALLY wet behind the ears here.

Comment 3 Gavin Gunnigle 2008-06-27 01:16:55 UTC
Okay, I'm repeating the steps, and I DEFinitely clicked "Additional Fedora
Software", and also selected "Customize now".

I still don't know how to get to the anaconda log while amidst an installation,
but if it's helpful, the project that's being downloaded when the prompt for
Disc 1 came back was kdelibs-common-4.0.3-7.fc9.i386

Comment 4 David J. Schwartz 2008-07-10 05:09:35 UTC
I had the same problem whilst installing
tomcat5-jasper-eclipse-5.2.26-1jpp.2.fc9.x86_64. I also selected Additional
Fedora Software and customized.

Comment 5 Chris Lumens 2008-07-11 21:13:38 UTC
*** Bug 454321 has been marked as a duplicate of this bug. ***

Comment 6 Jim Trocki 2008-08-01 02:04:52 UTC
I just tried the DVD installation under a vmware VM, selected the "Additional
Fedora Software" option, and it prompted for disc 1 to be inserted. I started
over, same options but did not select "Additional Fedora Software", and it did
not prompt.

Comment 7 Jim Trocki 2008-08-01 12:41:23 UTC
I did another fresh install with "Additional Fedora Software" selected to and it
did not show the "insert disc 1" prompt. I tried a couple more times but could
not reproduce the problem, so it seems like the "insert disc" behavior may be
related to the availability of the "additional software" repository mirror which
was used at the time.

Comment 8 Will Woods 2008-10-23 22:33:06 UTC
Woo. I tried to reproduce this bug with the F10Beta (snapshot 3) DVD and got some different (but equally wrong) behavior.

I selected the Rawhide repo (equivalent to the Additional Fedora Software checkbox), which prompted me to bring up the network. OK, fine. 

I then proceeded to enable the Window Manager group and request 3 packages that only exist in the Rawhide repo - WindowMaker, fluxconf, and fluxbox.

The resulting system installed only 265 packages - but included the 3 requested ones!

Attaching anaconda.log and the anaconda-ks.cfg.

Comment 9 Will Woods 2008-10-23 22:42:55 UTC
Created attachment 321349 [details]
anaconda.log

Comment 10 Will Woods 2008-10-23 22:44:13 UTC
Created attachment 321350 [details]
anaconda-ks.cfg

How did we end up with all those -[package] lines? I don't remember requesting that 'yum' be removed, or 'openssh-clients'. Sure made getting these logs tricky.

Comment 11 Chris Lumens 2008-10-24 19:06:36 UTC
I just did an x86_64 install of snapshot 3 under KVM following your instructions.  A quick post-reboot check shows:

# rpm -qa | wc -l
1088

WindowMaker and the fluxbox packages are installed.  The anaconda-ks.cfg file does not have a million - lines in it, and the three extra packages I selected are listed as well.  So I'm not sure what happened on your install, but I'm willing to close this one as RAWHIDE.  If we hit this weirdo issue again we can open a new one, I suppose.


Note You need to log in before you can comment on or make changes to this bug.