Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452928 - Crash when trying to assign packages from channel containing more than 2k packages
Summary: Crash when trying to assign packages from channel containing more than 2k pac...
Keywords:
Status: CLOSED DUPLICATE of bug 453176
Alias: None
Product: Spacewalk
Classification: Community
Component: Server
Version: 0.1
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Jesus M. Rodriguez
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: space02
TreeView+ depends on / blocked
 
Reported: 2008-06-25 22:57 UTC by Jason Ganovsky
Modified: 2012-03-06 08:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-30 14:59:39 UTC


Attachments (Terms of Use)

Description Jason Ganovsky 2008-06-25 22:57:02 UTC
Description of problem: I created a single channel with just over 2000 RPM's and
when I goto a registered system, then goto Software->Install New Packages I see
an error in the tomcat logs
2008-06-23 12:41:46,957 [TP-Processor1] WARN 
org.apache.struts.action.RequestProcessor - Unhandled Exception thrown: class
com.redhat.rhn.common.db.Wra
ppedSQLException
2008-06-23 12:41:47,004 [TP-Processor1] ERROR
com.redhat.rhn.frontend.servlets.SessionFilter - Error during transaction.
Rolling back
javax.servlet.ServletException: No more data to read from socket
        at
org.apache.struts.action.RequestProcessor.processException(RequestProcessor.java:535)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:433)
        at
org.apache.struts.action.RequestProcessor.process(RequestProcessor.java:237)
        at
com.redhat.rhn.frontend.struts.RhnRequestProcessor.process(RhnRequestProcessor.java:82)
        at org.apache.struts.action.ActionServlet.process(ActionServlet.java:1196)
        at org.apache.struts.action.ActionServlet.doGet(ActionServlet.java:414)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:690)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:803)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:269)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at com.redhat.rhn.frontend.servlets.AuthFilter.doFilter(AuthFilter.java:73)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at
com.opensymphony.module.sitemesh.filter.PageFilter.parsePage(PageFilter.java:142)
        at
com.opensymphony.module.sitemesh.filter.PageFilter.doFilter(PageFilter.java:58)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at
com.redhat.rhn.frontend.servlets.LocalizedEnvironmentFilter.doFilter(LocalizedEnvironmentFilter.java:67)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at
com.redhat.rhn.frontend.servlets.EnvironmentFilter.doFilter(EnvironmentFilter.java:107)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at
com.redhat.rhn.frontend.servlets.SessionFilter.doFilter(SessionFilter.java:55)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at
com.redhat.rhn.frontend.servlets.SetCharacterEncodingFilter.doFilter(SetCharacterEncodingFilter.java:97)
        at
org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:215)
        at
org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:188)
        at
org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:210)
        at
org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:174)
        at
org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:127)
        at
org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:117)
        at
org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:108)
        at
org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:151)
        at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:200)
        at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283)
        at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:773)
        at
org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:703)
        at
org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:895)
        at
org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:685)
        at java.lang.Thread.run(Thread.java:636)
Caused by: com.redhat.rhn.common.db.WrappedSQLException: No more data to read
from socket
        at
oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:112)
        at
oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:146)
        at
oracle.jdbc.driver.DatabaseError.throwSqlException(DatabaseError.java:208)
        at oracle.jdbc.driver.T4CMAREngine.unmarshalUB1(T4CMAREngine.java:1123)
        at oracle.jdbc.driver.T4CMAREngine.unmarshalSB1(T4CMAREngine.java:1075)
        at oracle.jdbc.driver.T4C8Oall.receive(T4C8Oall.java:480)
        at
oracle.jdbc.driver.T4CPreparedStatement.doOall8(T4CPreparedStatement.java:219)
        at
oracle.jdbc.driver.T4CPreparedStatement.executeForRows(T4CPreparedStatement.java:970)
        at
oracle.jdbc.driver.OracleStatement.executeMaybeDescribe(OracleStatement.java:1072)
        at
oracle.jdbc.driver.T4CPreparedStatement.executeMaybeDescribe(T4CPreparedStatement.java:854)
        at
oracle.jdbc.driver.OracleStatement.doExecuteWithTimeout(OracleStatement.java:1154)
        at
oracle.jdbc.driver.OraclePreparedStatement.executeInternal(OraclePreparedStatement.java:3370)
        at
oracle.jdbc.driver.OraclePreparedStatement.execute(OraclePreparedStatement.java:3476)
        at
com.mchange.v2.c3p0.impl.NewProxyPreparedStatement.execute(NewProxyPreparedStatement.java:651)
        at
com.redhat.rhn.common.db.NamedPreparedStatement.execute(NamedPreparedStatement.java:137)
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:448)
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:425)
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:329)
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:334)
        at
com.redhat.rhn.common.db.datasource.CachedStatement.execute(CachedStatement.java:274)
        at
com.redhat.rhn.common.db.datasource.SelectMode.execute(SelectMode.java:105)
        at com.redhat.rhn.manager.BaseManager.makeDataResult(BaseManager.java:57)
        at
com.redhat.rhn.manager.rhnpackage.PackageManager.systemAvailablePackages(PackageManager.java:232)
        at
com.redhat.rhn.frontend.action.rhnpackage.InstallPackageSetupAction.getDataResult(InstallPackageSetupAction.java:84)
        at
com.redhat.rhn.frontend.action.rhnpackage.InstallPackageSetupAction.execute(InstallPackageSetupAction.java:62)
        at
org.apache.struts.action.RequestProcessor.processActionPerform(RequestProcessor.java:431)
        ... 40 more
Caused by: java.sql.SQLException: No more data to read from socket



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:

Comment 1 Jason Ganovsky 2008-06-30 12:57:01 UTC
I've done some additional testing, and it appears this happens somewhere past
500 packages.  I loaded all the base RHEL RPM's alphabetically and the error
occurred right after loading the "g"'s

Comment 2 Jason Ganovsky 2008-06-30 14:59:39 UTC

*** This bug has been marked as a duplicate of 453176 ***


Note You need to log in before you can comment on or make changes to this bug.