Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452926 - Totem fails to play DVDs
Summary: Totem fails to play DVDs
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: totem
Version: 9
Hardware: All
OS: Linux
low
high
Target Milestone: ---
Assignee: Bastien Nocera
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 22:27 UTC by James Gregory
Modified: 2008-08-19 18:39 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-08-19 18:34:19 UTC


Attachments (Terms of Use)

Description James Gregory 2008-06-25 22:27:33 UTC
Description of problem:
When inserting a DVD, and select "Movie Player" from the list, Totem fails to
play the DVD. If I then click "Play Disc" from the Movie menu, the movie starts
playing, but without any access to the menu (this was possible before).

Checking my list of recently installed packages, this error appears to have
started since gstreamer-plugins-flumpegdemux was installed as part of the latest
Totem update on the 21 June. However, I already have the gstreamer bad and ugly
packages installed (and libdvdcss) which may be conflicting. However, I cannot
remove gstreamer-plugins-flumpegdemux as it is a dependency for Totem.

"totem --debug" does not show any errors when reading the DVD in either case.

Version-Release number of selected component (if applicable):
[james@ljam log]$ sudo yum list installed totem* gstreamer-plugins-flumpegdemux
libdvd*
gstreamer-plugins-flumpegdemux.i386      0.10.15-2.fc9          installed       
libdvdcss.i386                           1.2.9-5.lvn9           installed       
libdvdnav.i386                           4.1.2-1.fc9            installed       
libdvdread.i386                          4.1.2-1.fc9            installed       
totem.i386                               2.23.2-4.fc9           installed       
totem-gstreamer.i386                     2.23.2-4.fc9           installed       
totem-mozplugin.i386                     2.23.2-4.fc9           installed       
totem-nautilus.i386                      2.23.2-4.fc9           installed       
totem-pl-parser.i386                     2.22.3-1.fc9           installed       
totem-xine.i386                          2.23.2-4.fc9           installed      

How reproducible:
All the time

Steps to Reproduce:
1. Insert a DVD
2. Select "Movie Player" from the auto-play menu (or click "Open with Movie
Player" from the DVD icon)
  
Actual results:
The DVD will fail to play (it will be "Paused")

Expected results:
The DVD should start playing (usually with the copyright notices)

Comment 1 Bastien Nocera 2008-06-25 22:48:09 UTC
(In reply to comment #0)
> Description of problem:
> When inserting a DVD, and select "Movie Player" from the list, Totem fails to
> play the DVD. If I then click "Play Disc" from the Movie menu, the movie starts
> playing, but without any access to the menu (this was possible before).

This was never possible with the GStreamer backend. You had the xine-lib backend
installed. If you want to use the xine-lib backend, run "totem-backend -b xine".

> Actual results:
> The DVD will fail to play (it will be "Paused")

Try launching Totem, and selecting the DVD drive in the Movie menu instead. Does
it play back properly?


Comment 2 James Gregory 2008-06-25 23:11:01 UTC
Your suggestion (totem-backend -b xine) fixed the problem. How did the totem
backend get changed, as I certainly haven't altered anything...

(Just to answer your second question - the DVD played back if you selected the
DVD in the Movie menu. However, the menu screens were not available.)

Comment 3 Brad Longo 2008-08-19 18:01:34 UTC
I am having the same issue.  Totem will not play dvd's for me either.  I ran totem --sync and got this...
[ryan@localhost ~]$ totem --sync
libdvdread: Using libdvdcss version 1.2.9 for DVD access

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000134
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x000002c0
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x0000776f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x00284b51
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x00284b56
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x00284c3f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x00284c44
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_0.VOB at 0x00286fcd
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x00286fd2
libdvdread: Elapsed time 0
libdvdread: Found 4 VTS's
libdvdread: Elapsed time 0
libdvdread: Using libdvdcss version 1.2.9 for DVD access

libdvdread: Attempting to retrieve all CSS keys
libdvdread: This can take a _long_ time, please be patient

libdvdread: Get key for /VIDEO_TS/VIDEO_TS.VOB at 0x00000134
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_0.VOB at 0x000002c0
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_01_1.VOB at 0x0000776f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_0.VOB at 0x00284b51
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_02_1.VOB at 0x00284b56
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_0.VOB at 0x00284c3f
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_03_1.VOB at 0x00284c44
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_0.VOB at 0x00286fcd
libdvdread: Elapsed time 0
libdvdread: Get key for /VIDEO_TS/VTS_04_1.VOB at 0x00286fd2
libdvdread: Elapsed time 0
libdvdread: Found 4 VTS's
libdvdread: Elapsed time 0
No accelerated IMDCT transform found
No accelerated IMDCT transform found
No accelerated IMDCT transform found
No accelerated IMDCT transform found
No accelerated IMDCT transform found
The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 58 error_code 11 request_code 140 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Comment 4 Bastien Nocera 2008-08-19 18:34:19 UTC
(In reply to comment #2)
> Your suggestion (totem-backend -b xine) fixed the problem. How did the totem
> backend get changed, as I certainly haven't altered anything...

Typing the command did change the backend.

> (Just to answer your second question - the DVD played back if you selected the
> DVD in the Movie menu. However, the menu screens were not available.)

Great, that's what was expected in the F9 state of affairs. Fedora 10 (and the livna packages for Fedora 10) should have the plugins to allow DVD playback with menus in the GStreamer backend. See http://gstreamer.freedesktop.org/wiki/DvdPlayback?action=show

Closing as the problem is fixed now.

(In reply to comment #3)
> I am having the same issue.  Totem will not play dvd's for me either.  I ran
> totem --sync and got this...
> [ryan@localhost ~]$ totem --sync
<snip>
> The program 'totem' received an X Window System error.
> This probably reflects a bug in the program.
> The error was 'BadAlloc (insufficient resources for operation)'.
>   (Details: serial 58 error_code 11 request_code 140 minor_code 19)
>   (Note to programmers: normally, X errors are reported asynchronously;
>    that is, you will receive the error a while after causing it.
>    To debug your program, run it with the --sync command line
>    option to change this behavior. You can then get a meaningful
>    backtrace from your debugger if you break on the gdk_x_error() function.)

Your problem is with your video driver. File a separate bug against the package that corresponds to your video driver.

Comment 5 Brad Longo 2008-08-19 18:39:28 UTC
will do


Note You need to log in before you can comment on or make changes to this bug.