Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452922 - Update metrics to ensure routing is correct with multiple interfaces
Summary: Update metrics to ensure routing is correct with multiple interfaces
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Dan Williams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 21:25 UTC by Aidan Skinner
Modified: 2009-02-14 20:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-02-14 20:29:18 UTC


Attachments (Terms of Use)
grep NetworkManager /var/log/messages (deleted)
2008-06-25 21:25 UTC, Aidan Skinner
no flags Details

Description Aidan Skinner 2008-06-25 21:25:15 UTC
Description of problem:
When I plug in an ethernet cable to my thinkpad z61 network manager dhcps
correctly, but does not drop the wireless connection and apps continue to use
it. I have to disable wireless to use the cable I just plugged in. 

Version-Release number of selected component (if applicable):
0.7.0-0.9.4.svn3675.fc9

How reproducible:
Happens every time

Steps to Reproduce:
1. Connect to wlan 
2. Plug in ethernet cable
3. Watch icon change to indicate wired
  
Actual results:
Network uses wlan0

Expected results:
Network uses eth0

Additional info:
Wireless is Intel PRO/Wireless 3945ABG
Ethernet is Broadcom BCM5752M

Comment 1 Aidan Skinner 2008-06-25 21:25:15 UTC
Created attachment 310298 [details]
grep NetworkManager /var/log/messages

Comment 2 Aidan Skinner 2008-06-28 09:31:52 UTC
This also happens on my Thinkpad T41, atheros AR5212 wlan and Intel 82540EP ethernet

Comment 3 Dan Williams 2008-07-02 23:19:49 UTC
This is by design and one of the major features of 0.7; NetworkManager keeps
available devices up so that your apps don't break when you switch.  It changes
the default route so that new connections will use the new default device. 
What's the output of '/sbin/route -n' in your situation?

Comment 4 Aidan Skinner 2008-07-17 01:08:43 UTC
Ok, that makes sense (and is rather nifty), but it sounds like the new
connections aren't defaulting properly.

[aidan@thoughtful ~]$ /sbin/route  -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 wlan0
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.1.1     0.0.0.0         UG    0      0        0 eth0

(this would be less of a problem without #453278)

Comment 5 Dan Williams 2008-07-17 13:35:04 UTC
Yeah, we probably need to update metrics to ensure that eth0 is really being used.

Comment 6 Dan Williams 2009-02-14 20:29:18 UTC
This functionality got into NM on 2008-09-30.  Should be long-since fixed.


Note You need to log in before you can comment on or make changes to this bug.