Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452905 - Add support for server.applet.poll_packages to return arch data.
Summary: Add support for server.applet.poll_packages to return arch data.
Keywords:
Status: CLOSED DUPLICATE of bug 452902
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server
Version: 511
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: John Matthews
QA Contact: Brandon Perkins
URL:
Whiteboard:
Depends On: 452902
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 18:55 UTC by John Matthews
Modified: 2008-10-08 16:17 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-10-08 16:17:40 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description John Matthews 2008-06-25 18:55:20 UTC
+++ This bug was initially created as a clone of Bug #452902 +++

Description of problem:
rhn-applet is unable to distinguish between updates for packages of different archs.
Example:  on a 64bit OS, install 32bit firefox.i386 (1 rev older than latest).
Look at updated packages rhn-applet sees, it will mistakenly display an update
is available for firefox.x86_64, even when that package isn't installed.

Desire is to add "arch" data to each package returned from poll_packages.


Related to bug#232654

Comment 1 Clifford Perry 2008-10-08 16:17:40 UTC

*** This bug has been marked as a duplicate of bug 452902 ***


Note You need to log in before you can comment on or make changes to this bug.