Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 4529 - rpm-3.0.3-0.12: Package upgrade VERY BROKEN
Summary: rpm-3.0.3-0.12: Package upgrade VERY BROKEN
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: rpm
Version: 1.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-08-15 03:49 UTC by Brian Ryner
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-08-15 14:50:41 UTC


Attachments (Terms of Use)

Description Brian Ryner 1999-08-15 03:49:01 UTC
After upgrading to rpm-3.0.3-0.12, rpm -Uvh is causing
severe problems for me.  It appears to enter the new package
version in the rpm database, and remove the old version, but
the files from the new version are NEVER INSTALLED.  So I am
left with the package completely gone.

This happened for me on both rawhide-release-19990814-1 and
tar-1.13.6-1.  Installing from scratch (also with rpm -Uvh)
does not seem to be affected by this bug.

Comment 1 Jeff Johnson 1999-08-15 14:50:59 UTC
Fixed in rpm-3.0.3-13.


Note You need to log in before you can comment on or make changes to this bug.