Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452893 - Existing Entity Commands chapter specifies classes in wrong, outdated packages
Summary: Existing Entity Commands chapter specifies classes in wrong, outdated packages
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: JBoss Enterprise Application Platform 4
Classification: JBoss
Component: doc-Server_Configuration_Guide
Version: 4.2.0
Hardware: All
OS: Linux
low
low
Target Milestone: ---
: ---
Assignee: Isaac Rooskov
QA Contact: Content Services Development
URL: http://www.redhat.com/docs/manuals/jb...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 16:50 UTC by Aleksander Adamowski
Modified: 2015-08-06 05:54 UTC (History)
3 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-26 02:27:35 UTC
Type: ---


Attachments (Terms of Use)

Description Aleksander Adamowski 2008-06-25 16:50:32 UTC
Description of problem:

In the Server Configuration Guide, chapter "15.11.1. Existing Entity Commands"
(http://www.redhat.com/docs/manuals/jboss/jboss-eap-4.2/doc/Server_Configuration_Guide/Entity_Commands_and_Primary_Key_Generation-Existing_Entity_Commands.html)
specifies entity-command definitions along with corresponding classes.

The classes are listed in wrong packages (probably leftover from an older JBoss
release), e.g. org.jboss.ejb.plugins.cmp.jdbc.hsqldb.JDBCHsqldbCreateCommand
should now be org.jboss.ejb.plugins.cmp.jdbc.keygen.JDBCHsqldbCreateCommand.

Generally, all vendor specific create command classes seem to have been moved
into org.jboss.ejb.plugins.cmp.jdbc.keygen, judging from SVN trunk:
http://anonsvn.jboss.org/repos/jbossas/trunk/server/src/main/org/jboss/ejb/plugins/cmp/jdbc/keygen/

Comment 1 Isaac Rooskov 2008-06-26 02:27:35 UTC
Closing this bugzilla and migrating the issue to JIRA for tracking within the
scope of the projects bug tracking. 

This issue can now be followed publicly via the following link:
http://jira.jboss.com/jira/browse/JBPAPP-926

Comment 2 IBM Mirproxy 2008-08-11 20:10:41 UTC
=Comment: #0=================================================
mirproxy <mirproxy@us.ibm.com> -
Outside it is raining and thundering.

The grass and trees are happy.
Bug received in the Red Hat Bugzilla test system:

https://partner-bugzilla.redhat.com/show_bug.cgi?id=452893
------- Comment From bugproxy@us.ibm.com 2008-07-31 11:27:16 EDT-------
Attempt to assign the bug to bugproxy.
Added a text attachment to the LTC bug.
However, I suspect attachments are not being extracted just yet, so this will not appear in the RH bug.
------- Comment From bugproxy@us.ibm.com 2008-07-31 11:53:21 EDT-------
Testing a code change on the Red Hat Bugzilla side.
------- Comment From bugproxy@us.ibm.com 2008-07-31 16:30:11 EDT-------
Try a state change ... ON_DEV ... see what happens ...
------- Comment From bugproxy@us.ibm.com 2008-08-01 10:00:30 EDT-------
Close out this test bug. Plan for another w/o attachments.
Closing this test bug.
------- Comment From bugproxy@us.ibm.com 2008-08-01 10:30:34 EDT-------
*** Bug 452895 has been marked as a duplicate of this bug. ***
---Problem Description---
Another bug to test interaction with Red Hat Bugzilla 3.2
... getting sleepy ...

Contact Information = n/a

---uname output---
n/a

Machine Type = n/a

---Debugger---
A debugger is not configured

Java Version: n/a

-Note: Problem does not occurs with the JIT compiler disabled
------- Comment From bugproxy@us.ibm.com 2008-08-01 10:11:56 EDT-------
Test status change, owner change, severity change, target milestone change
------- Comment From bugproxy@us.ibm.com 2008-08-01 10:20:42 EDT-------
Testing the POST status.
------- Comment From bugproxy@us.ibm.com 2008-08-01 10:23:11 EDT-------
Try CLOSED CANTFIX ... check the mirroring effect.
Can the Red Hat bug be reopened?
------- Comment From bugproxy@us.ibm.com 2008-08-01 10:25:24 EDT-------
Anticipating the next request, the bug is reopened.
Test closing this bug as a dup of another.

*** This bug has been marked as a duplicate of bug 452893 ***

------- Comment From bugproxy@us.ibm.com 2008-08-01 10:59:56 EDT-------
The mirroring for the duplicate bug was obsoleted.
Inspect to determine where this comment is mirrored to.

Comment 3 IBM Bug Proxy 2008-08-11 20:27:53 UTC
My apologies; please disregard Comment #2. This was a test against an identically numbered bug in the pre-release Red Hat Bugzilla 3.1.4 test environment and should not have been applied to this bug.


Note You need to log in before you can comment on or make changes to this bug.