Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452877 - rhn_check has traceback when disk is full
Summary: rhn_check has traceback when disk is full
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.6
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Sayli Karmarkar
QA Contact: Jeff Browning
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 15:33 UTC by Petr Sklenar
Modified: 2015-03-23 01:09 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-05-18 20:14:09 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2009:0972 normal SHIPPED_LIVE up2date bug fix update 2009-05-18 13:42:03 UTC

Description Petr Sklenar 2008-06-25 15:33:38 UTC
Description of problem:
rhn_check has traceback when disk is full

Version-Release number of selected component (if applicable):
# rpm -q up2date
up2date-4.7.1-17.el4
# uname -a
Linux proliant04.englab.brq.redhat.com 2.6.9-67.ELsmp #1 SMP Wed Nov 7 13:58:04
EST 2007 i686 i686 i386 GNU/Linux

How reproducible:
always

Steps to Reproduce:
1. disk has very very low space, for ex none ...
test it with = "dd if=/dev/zero of=/huge"
2. RHN | schedule some package to install
3. your machine: rhn_check
  
Actual results:
sometimes traceback, 
sometimes strange end of installing process with "echo $?=0"

traceback: 
[root@proliant04 8295]# rhn_check 

Name                                    Version        Rel     
----------------------------------------------------------
amanda                                  2.4.4p3        1                 i386  

Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 345, in ?
    handle_action(action)
  File "/usr/sbin/rhn_check", line 218, in handle_action
    (status, message, data) = run_action(method, params)
  File "/usr/sbin/rhn_check", line 174, in run_action
    (status, message, data) = do_call(method, params)   
  File "/usr/sbin/rhn_check", line 91, in do_call
    retval = apply(method, params)
  File "/usr/share/rhn/actions/packages.py", line 353, in update
    ret = _catchErrors(batchRun, "packages.update", (0, pkgList))
  File "/usr/share/rhn/actions/packages.py", line 329, in _catchErrors
    data['space_available'] = e.freeDiskSpace
AttributeError: OutOfSpaceError instance has no attribute 'freeDiskSpace'

Expected results:
There should be same message like up2date <package> has: 
#up2date amanda
.
.
.
There was an error installing the packages. The message was:
The total size of the selected packages (84 kB) exceeds your free disk space (0 kB).

Additional info:

Comment 4 Jeff Browning 2009-04-03 19:02:17 UTC
[root@fjs-0-01 /]# rhn_check 
Traceback (most recent call last):
  File "/usr/sbin/rhn_check", line 341, in ?
    up2dateAuth.updateLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 144, in updateLoginInfo
    log.log_me("updating login info")
  File "/usr/share/rhn/up2date_client/up2dateLog.py", line 30, in log_me
    self.write_log(s)
  File "/usr/share/rhn/up2date_client/up2dateLog.py", line 55, in write_log
    log_file.flush()
IOError: [Errno 28] No space left on device


Verified. As per Sayli, this is the intended result of the fix.

Comment 6 errata-xmlrpc 2009-05-18 20:14:09 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0972.html


Note You need to log in before you can comment on or make changes to this bug.