Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452873 - system-config-printer does not understand AllowUser/DenyUser directives in printers.conf
Summary: system-config-printer does not understand AllowUser/DenyUser directives in pr...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: system-config-printer
Version: 4.6
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Tim Waugh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 15:05 UTC by Christoph Szeppek
Modified: 2008-06-27 11:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-27 11:28:32 UTC


Attachments (Terms of Use)

Description Christoph Szeppek 2008-06-25 15:05:02 UTC
Description of problem:
cupsd contained in cups-1.1.22-0.rc1.9.20.2.el4_6.6 understands AllowUser and
DenyUser statements in printers.conf file. When adding AllowUser/DenyUser to my
printers.conf file and running system-config-printer afterwards, the
AllowUser/DenyUser statement will be deleted, if system-config-printer rewrites
the printers.conf file.

Version-Release number of selected component (if applicable):
system-config-printer-0.6.116.10-1.2
cups-1.1.22-0.rc1.9.20.2.el4_6.6

How reproducible:
always

Steps to Reproduce:
1. Add a AllowUser or DenyUser statement to one of your printers in
/etc/cups/printers.conf (either by running "lpadmin -p <printer_name> -u
[allow|deny]:<user>" or manually editing the printers.conf file)
2. run system-config-printer, select a printer, click edit, then ok (nothing
changed)
3. Exit system-config-printer with "Save" (in order to write the printers.conf file)
  
Actual results:
The previously added AllowUser/DenyUser statement cannot be found in the
printers.conf file.

Expected results:
The AllowUser/DenyUser statement remains in the printers.conf file

Additional info:

Comment 1 Tim Waugh 2008-06-27 11:28:32 UTC
This is a design limitation of printconf 0.6.x.  It is not possible to make
changes to printconf-managed printers by any other tool than printconf.

This restriction is not present in Red Hat Enterprise Linux 5 due to the
printing configuration tool having an entirely new architecture.


Note You need to log in before you can comment on or make changes to this bug.