Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452862 - SELinux is preventing gdb (xdm_t) "getattr" to /var/lib/rpm/Packages (rpm_var_lib_t).
Summary: SELinux is preventing gdb (xdm_t) "getattr" to /var/lib/rpm/Packages (rpm_var...
Keywords:
Status: CLOSED DUPLICATE of bug 452861
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Ben Levenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 13:53 UTC by Jeff Moyer
Modified: 2008-06-26 12:01 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-26 12:01:13 UTC


Attachments (Terms of Use)

Description Jeff Moyer 2008-06-25 13:53:15 UTC
Description of problem:

Summary:

SELinux is preventing gdb (xdm_t) "getattr" to /var/lib/rpm/Packages
(rpm_var_lib_t).

Detailed Description:

SELinux denied access requested by gdb. It is not expected that this access is
required by gdb and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

Sometimes labeling problems can cause SELinux denials. You could try to restore
the default system file context for /var/lib/rpm/Packages,

restorecon -v '/var/lib/rpm/Packages'

If this does not work, there is currently no automatic way to allow this access.
Instead, you can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:rpm_var_lib_t:s0
Target Objects                /var/lib/rpm/Packages [ file ]
Source                        gdb
Source Path                   /usr/bin/gdb
Port                          <Unknown>
Host                          segfault.boston.devel.redhat.com
Source RPM Packages           gdb-6.8-1.fc9
Target RPM Packages           rpm-4.4.2.3-2.fc9
Policy RPM                    selinux-policy-3.3.1-42.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall_file
Host Name                     segfault.boston.devel.redhat.com
Platform                      Linux segfault.boston.devel.redhat.com
                              2.6.25-14.fc9.x86_64 #1 SMP Thu May 1 06:06:21 EDT
                              2008 x86_64 x86_64
Alert Count                   98
First Seen                    Tue 24 Jun 2008 09:10:10 AM EDT
Last Seen                     Tue 24 Jun 2008 09:10:23 AM EDT
Local ID                      df2c806c-0728-4f09-b654-1c263db81630
Line Numbers                  

Raw Audit Messages            

host=segfault.boston.devel.redhat.com type=AVC msg=audit(1214313023.629:248):
avc:  denied  { getattr } for  pid=3975 comm="gdb" path="/var/lib/rpm/Packages"
dev=sdb3 ino=30446 scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023
tcontext=system_u:object_r:rpm_var_lib_t:s0 tclass=file

host=segfault.boston.devel.redhat.com type=SYSCALL
msg=audit(1214313023.629:248): arch=c000003e syscall=4 success=no exit=-13
a0=2f460d0 a1=7fff0d7a6520 a2=7fff0d7a6520 a3=1a4 items=0 ppid=3974 pid=3975
auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0
tty=(none) ses=4294967295 comm="gdb" exe="/usr/bin/gdb"
subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 key=(null)

Comment 1 Daniel Walsh 2008-06-26 12:01:13 UTC

*** This bug has been marked as a duplicate of 452861 ***


Note You need to log in before you can comment on or make changes to this bug.