Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452857 - SELinux is preventing updatedb (locate_t) "read write" to socket (crond_t).
Summary: SELinux is preventing updatedb (locate_t) "read write" to socket (crond_t).
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 452858 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 13:45 UTC by Jeff Moyer
Modified: 2008-09-09 19:30 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-09-09 19:30:45 UTC


Attachments (Terms of Use)

Description Jeff Moyer 2008-06-25 13:45:33 UTC
Description of problem:

Summary:

SELinux is preventing updatedb (locate_t) "read write" to socket (crond_t).

Detailed Description:

SELinux denied access requested by updatedb. It is not expected that this access
is required by updatedb and this access may signal an intrusion attempt. It is
also possible that the specific version or configuration of the application is
causing it to require additional access.

Allowing Access:

You can generate a local policy module to allow this access - see FAQ
(http://fedora.redhat.com/docs/selinux-faq-fc5/#id2961385) Or you can disable
SELinux protection altogether. Disabling SELinux protection is not recommended.
Please file a bug report (http://bugzilla.redhat.com/bugzilla/enter_bug.cgi)
against this package.

Additional Information:

Source Context                system_u:system_r:locate_t:s0-s0:c0.c1023
Target Context                system_u:system_r:crond_t:s0-s0:c0.c1023
Target Objects                socket [ tcp_socket ]
Source                        updatedb
Source Path                   /usr/bin/updatedb
Port                          <Unknown>
Host                          segfault.boston.devel.redhat.com
Source RPM Packages           mlocate-0.20-1
Target RPM Packages           
Policy RPM                    selinux-policy-3.3.1-64.fc9
Selinux Enabled               True
Policy Type                   targeted
MLS Enabled                   True
Enforcing Mode                Enforcing
Plugin Name                   catchall
Host Name                     segfault.boston.devel.redhat.com
Platform                      Linux segfault.boston.devel.redhat.com
                              2.6.25.6-55.fc9.x86_64 #1 SMP Tue Jun 10 16:05:21
                              EDT 2008 x86_64 x86_64
Alert Count                   1
First Seen                    Wed 25 Jun 2008 04:35:07 AM EDT
Last Seen                     Wed 25 Jun 2008 04:35:07 AM EDT
Local ID                      194a1b9f-a06a-4b24-a882-ad01d222dba6
Line Numbers                  

Raw Audit Messages            

host=segfault.boston.devel.redhat.com type=AVC msg=audit(1214382907.101:279):
avc:  denied  { read write } for  pid=11541 comm="updatedb"
path="socket:[2058152]" dev=sockfs ino=2058152
scontext=system_u:system_r:locate_t:s0-s0:c0.c1023
tcontext=system_u:system_r:crond_t:s0-s0:c0.c1023 tclass=tcp_socket

host=segfault.boston.devel.redhat.com type=SYSCALL
msg=audit(1214382907.101:279): arch=c000003e syscall=59 success=yes exit=0
a0=250d220 a1=250e340 a2=250f160 a3=32c3367a70 items=0 ppid=11535 pid=11541
auid=0 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=27
comm="updatedb" exe="/usr/bin/updatedb"
subj=system_u:system_r:locate_t:s0-s0:c0.c1023 key=(null)

Comment 1 Daniel Walsh 2008-06-26 11:57:03 UTC
*** Bug 452858 has been marked as a duplicate of this bug. ***

Comment 2 Daniel Walsh 2008-09-09 19:30:45 UTC
Fixed in selinux-policy-3.3.1-89.1.fc9


Note You need to log in before you can comment on or make changes to this bug.