Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452851 - libvpd library number bumped down
Summary: libvpd library number bumped down
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: libvpd
Version: 9
Hardware: i386
OS: Linux
low
medium
Target Milestone: ---
Assignee: Eric Munson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 13:18 UTC by J. Randall Owens
Modified: 2008-12-11 08:02 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-11 08:02:30 UTC


Attachments (Terms of Use)

Description J. Randall Owens 2008-06-25 13:18:43 UTC
Description of problem:
lsvpd-1.6.4-1.fc9 requires libraries from libvpd-2.0.1, although it was built &
released simultaneously with libvpd-2.0.2.  Further investigation shows that
libvpd-2.0.1 provided libvpd(_cxx)?-2.0.so.1, but libvpd-2.0.2 provides
libvpd(_cxx)?-2.0.so.0

Version-Release number of selected component (if applicable):
libvpd-2.0.2-1.fc9 & lsvpd-1.6.4-1.fc9

How reproducible:
try to update from repository

Steps to Reproduce:
1. yum update
  
Actual results:
lsvpd insists on keeping libvpd-2.0.1 installed

Expected results:
libvpd updates to 2.0.2

Additional info:
The numbers on the /usr/lib/libvpd* files match those in the RPM provides
information.

Comment 1 J. Randall Owens 2008-06-25 22:33:30 UTC
Alternatively for actual results, I'll also get the option to uninstall lsvpd
instead.  I declined.

Comment 2 Michael Schwendt 2008-08-08 12:20:54 UTC
A rebuild of lsvpd would suffice.

libvpd 2.0.3 is available since June 11th and stays at soname
major version 0.

Comment 3 Michael Schwendt 2008-09-12 12:06:50 UTC
Ping!

Status update, please. Over two months have passed without a
reply and without a fix.

Comment 4 Eric Munson 2008-09-12 16:24:21 UTC
The new libvpd source should fix the problem, I will add it to the F-9 repo.

Comment 5 Michael Schwendt 2008-10-10 22:15:23 UTC
Package is still broken in the repository.
You are upstream even.

[...]

Btw, all manual pages refer to a wrong path:

FILES
       /var/lib/lsvpd/db
              Database file used by ...

Comment 6 Michael Schwendt 2008-10-10 22:16:28 UTC
It would make sense to %ghost run-time created files
in: /var/lib/lsvpd/

Comment 7 Eric Munson 2008-11-24 21:21:06 UTC
I have committed what I believe to be a fix to the F-9 updates and devel on September 12, I am not sure what else I need to do to get that into the repository.

Comment 8 Michael Schwendt 2008-11-24 23:10:24 UTC
There is no such update:

  https://admin.fedoraproject.org/updates/search/libvpd
  https://admin.fedoraproject.org/updates/search/lsvpd

No recent builds either:

libvpd: http://koji.fedoraproject.org/koji/packageinfo?packageID=5671
lsvpd: http://koji.fedoraproject.org/koji/packageinfo?packageID=5976

You need to submit build jobs (to koji) and submit update
requests (in bodhi). Just committing files in cvs is not enough.

Perhaps ask your sponsor for help?

Comment 10 Fedora Update System 2008-12-03 01:23:13 UTC
lsvpd-1.6.4-1.fc9.1 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing-newkey update lsvpd'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-10618

Comment 11 Fedora Update System 2008-12-11 08:02:25 UTC
lsvpd-1.6.4-1.fc9.1 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.