Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452839 - --get-source gets wrong srpm and actually resolves dependencies
Summary: --get-source gets wrong srpm and actually resolves dependencies
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: up2date
Version: 4.7
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Pradeep Kilambi
QA Contact: Fanny Augustin
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 12:35 UTC by Michal Nowak
Modified: 2013-03-08 02:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-06-26 11:56:06 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Michal Nowak 2008-06-25 12:35:06 UTC
Description of problem:

  --get-source          Fetch the source package for the specified package
                        without resolving dependencies


[root@xen65 ~]# rm /var/spool/up2date/* -f
[root@xen65 ~]# up2date --get-source xsane-gimp

Fetching all package list for channel: rhel-i386-as-4...
########################################

Fetching package list for channel: rhel-i386-as-4...
########################################

xsane-0.92-13.src.rpm...
[root@xen65 ~]# ll /var/spool/up2date/
total 4904
-rw-r--r--  1 root root  545163 Jun 25 14:20 rhel-i386-as-4.20080625073945
-rw-r--r--  1 root root 1773074 Jun 25 14:20 rhel-i386-as-4-all.20080625073945
-rw-r--r--  1 root root 2655116 Jun 25 14:20 xsane-0.92-13.src.rpm
-rw-r--r--  1 root root    8600 Jun 25 14:20 xsane-gimp-0.92-13.i386.hdr


xsane and xsane-gimp are not installed at the beginning.


Concerns:

1. I get source package of xsane but *not* of xsane-gimp. Note that the right
hdr was downloaded.

2. In man it says that it does not solve dependencies but it actually does (the
xsane in spool).

Version-Release number of selected component (if applicable):

4.7.1-17.el4 + latest EUS 4.6.2-8

How reproducible:
always

Steps to Reproduce:
1. erase spool
2. install pkg which has dependency
3. see spool there's srpm pkg of dependency but not from the pkg intended to be
got/downloaded.
  
Actual results:

xsane.rpm

Expected results:

xsane-gimp.rpm

Comment 3 Michal Nowak 2008-06-26 09:34:56 UTC
Could anyone state on whether such behavior is right or not? It's not making me
any sence :).


Note You need to log in before you can comment on or make changes to this bug.