Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452835 - [compiz] OpenOffice.org Impress shows previous slide artifacts fullscreen
Summary: [compiz] OpenOffice.org Impress shows previous slide artifacts fullscreen
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 12:22 UTC by Domingo Becker
Modified: 2008-07-31 08:25 UTC (History)
2 users (show)

Fixed In Version: F-9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-31 08:25:47 UTC


Attachments (Terms of Use)
the wrong rendered image when in F5 (deleted)
2008-06-25 12:22 UTC, Domingo Becker
no flags Details
a presentation file to see the bug (deleted)
2008-06-25 12:25 UTC, Domingo Becker
no flags Details

Description Domingo Becker 2008-06-25 12:22:20 UTC
Description of problem:
OO.o Impress shows incorrect images for the slides of a presentation.
It normally used to crash when trying to show the presentation (pressing F5),
but with today's update 2.4.1-17.4.fc9 it doesn't crash anymore.
But it shows wrong images.

Version-Release number of selected component (if applicable):
openoffice.org-2.4.1-17.4.fc9

How reproducible:
Open the attached presentation file and press F5.

Steps to Reproduce:
1. Open the presentation file attached
2. Press F5, then press an arrow key or click with the mouse to go to next
screen. It will render a wrong image.
3.
  
Actual results:
The results are shown in the png attached image.

Expected results:


Additional info:
My smolt: http://www.smolts.org/show?uuid=pub_66965710-8ee7-48ec-acdd-3cac71e6d60d

I have desktop effects enabled.

Comment 1 Domingo Becker 2008-06-25 12:22:20 UTC
Created attachment 310257 [details]
the wrong rendered image when in F5

Comment 2 Domingo Becker 2008-06-25 12:25:01 UTC
Created attachment 310258 [details]
a presentation file to see the bug

Comment 3 Caolan McNamara 2008-07-08 15:37:56 UTC
I see it with compiz enabled (most times, but not always), and not with it
disabled. I'd like to blame some compiz problem, but I'm unsure as to how to
prove that one way or the other.

caolanm->ajax: any tips on identifying the culprit here ?

Comment 4 Domingo Becker 2008-07-08 21:55:39 UTC
Thanks for the tip Caolan.
It works fine with compiz disabled.
It seems to be a problem with compiz-gnome instead of openoffice.
oo.o writer and calc do something strange too, not always (to test it, open a
long document and press the down arrow key).
I tested oo.o impress and it works.
I'm testing oo.o writer, and it seems to work fine so far, with desktop effects
disabled.
There's another culprit and I think it's compiz-gnome.
For my presentations I will use my F9 with compiz disabled until this bug is fixed.

Thanks again.

Domingo Becker (es)


Comment 5 Domingo Becker 2008-07-28 11:40:33 UTC
The bug is fixed.
I tested today after an update and it does not those strange things anymore. 
The fix came in an update between 2008-07-08 and 2008-07-28. I can't say which
one because I wasn't testing since the last comment.
Thanks a lot.

Domingo Becker


Comment 6 Caolan McNamara 2008-07-31 08:25:47 UTC
Well, what'd you know, the same here. Must have gotten fixed in some other
component after all :-)


Note You need to log in before you can comment on or make changes to this bug.