Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452829 - Unhandled exception in handling of cached login data.
Summary: Unhandled exception in handling of cached login data.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: rhn-client-tools
Version: 5.2
Hardware: All
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pradeep Kilambi
QA Contact:
URL:
Whiteboard:
: 461554 466862 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 11:55 UTC by Martin Poole
Modified: 2018-10-20 03:22 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-20 22:17:37 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
IBM Linux Technology Center 44433 None None None Never
Red Hat Product Errata RHBA-2009:0249 normal SHIPPED_LIVE rhn-client-tools bug fix update 2009-01-20 16:06:51 UTC

Description Martin Poole 2008-06-25 11:55:52 UTC
Description of problem:

The recently included login caching code in
/usr/share/rhn/up2date_client/up2dateAuth.py does not gracefully handle a
failure when attempting to unpickle the stored data.

Version-Release number of selected component (if applicable):

0.4.17-8.el5

How reproducible:
always

Steps to Reproduce:
1. yum check-update
2. cat /dev/null >/var/spool/up2date/loginAuth.pkl
3. yum check-update
  
Actual results:

Loading "security" plugin
Loading "rhnplugin" plugin
Traceback (most recent call last):
  File "/usr/bin/yum", line 29, in ?
    yummain.main(sys.argv[1:])
  File "/usr/share/yum-cli/yummain.py", line 85, in main
    base.getOptionsConfig(args)
  File "/usr/share/yum-cli/cli.py", line 163, in getOptionsConfig
    disabled_plugins=self.optparser._splitArg(opts.disableplugins))
  File "/usr/lib/python2.4/site-packages/yum/__init__.py", line 183, in _getConfig
    self.plugins.run('init')
  File "/usr/lib/python2.4/site-packages/yum/plugins.py", line 169, in run
    func(conduitcls(self, self.base, conf, **kwargs))
  File "/usr/lib/yum-plugins/rhnplugin.py", line 110, in init_hook
    login_info = up2dateAuth.getLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 211, in getLoginInfo
    login()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 159, in login
    if readCachedLogin():
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 120, in readCachedLogin
    data = pickle.load(pcklAuth)
  File "/usr/lib/python2.4/pickle.py", line 1390, in load
    return Unpickler(file).load()
  File "/usr/lib/python2.4/pickle.py", line 872, in load
    dispatch[key](self)
  File "/usr/lib/python2.4/pickle.py", line 894, in load_eof
    raise EOFError
EOFError


Expected results:

Handle error as if file was not present.

Additional info:

Comment 1 RHEL Product and Program Management 2008-06-25 12:13:08 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 3 Pradeep Kilambi 2008-08-20 16:29:49 UTC
fixed!

Comment 4 John Matthews 2008-09-11 17:14:36 UTC
*** Bug 461554 has been marked as a duplicate of this bug. ***

Comment 8 errata-xmlrpc 2009-01-20 22:17:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2009-0249.html

Comment 10 Pradeep Kilambi 2009-02-24 19:55:22 UTC
*** Bug 466862 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.