Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452818 - fully virtualized guests do not start when using routed xen configuration
Summary: fully virtualized guests do not start when using routed xen configuration
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen
Version: 5.2
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 10:05 UTC by Martin Jürgens
Modified: 2009-12-14 21:26 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-11 13:50:02 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Martin Jürgens 2008-06-25 10:05:16 UTC
Description of problem:
Because of internal infrastructure, I cannot use bridged XEN configuration but
have to use routed XEN configuration instead. I have modified the xen config
file to use it, and it works fine for paravirtualized guests.

The problem is the following: When I try to start fully virtualized guests
having ip=xx.xx.xx.xx and no bridge set, they do not start with the following
error message:

Watching /local/domain/4/logdirty/next-active
/etc/xen/qemu-ifup: could not launch network script
Could not initialize device 'tap'


How reproducible:
Always

Steps to Reproduce:
1. Switch to routed networking
2. Create fully virtualized guest
3. Start it
  
Actual results:
Does not start with error message above

Expected results:
Should start

Additional info:
-/-

Comment 1 Daniel Berrange 2008-07-11 13:50:02 UTC
The default network configuration script for HVM guests only supports bridged
networking configurations. 

If you want to use a non-bridged network, you will need to manually change the
/etc/xen/qemu-ifup script to handle your custom requirements.



Note You need to log in before you can comment on or make changes to this bug.