Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452814 - Bookmarks import from Mozilla fails
Summary: Bookmarks import from Mozilla fails
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 9
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Gecko Maintainer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: 2Bupstreamed
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 09:13 UTC by Tethys
Modified: 2018-04-11 11:04 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-01 15:10:48 UTC


Attachments (Terms of Use)

Description Tethys 2008-06-25 09:13:55 UTC
Description of problem:
Import of bookmarks from Mozilla doesn't work.

Version-Release number of selected component (if applicable):
firefox-3.0-1.fc9.x86_64

How reproducible:
Every time

Steps to Reproduce:
1. File -> Import...
2. Select Netscape 6, 7 or Mozilla 1.x
  
Actual results:
Bookmarks not imported. All I get is an empty bookmark
folder with the name "From Netscape 6/7/Mozilla". At first
glance, it looks like cookies were imported OK, it's just
bookmarks that failed, but I'm not 100% certain of that.

Expected results:
Everything imported OK

Additional info:
Bookmark import does work if it's done via the "Import and backup"
menu in the "Organize bookmarks" dialog. Just not if done from the
File->Import menu.

Comment 1 Matěj Cepl 2008-06-25 16:09:53 UTC
Are you able to reproduce the same behavior with the upstream binary from
http://www.mozilla.com/products/download.html?product=firefox-3.0&os=linux&lang=en-US
???

Thanks for a reply.

Comment 2 Tethys 2008-06-26 00:14:28 UTC
Similar, but slightly different behaviour with the upstream binary. If
I use the import on first launch option, it works fine, and everything
appears to have been imported OK. If I choose not to import anything
at first launch, and then later try to do so via the File->Import menu,
it fails. However, where the Fedora version at least gives me an empty
"From Netscape 6/7/Mozilla" folder in my bookmarks to show that it's
tried to do something, the upstream binary gives me nothing at all.


Comment 3 Matěj Cepl 2008-07-01 15:10:48 UTC
We found that this bug has been already registered in the upstream database
(https://bugzilla.mozilla.org/show_bug.cgi?id=215094) and believe that it is
more appropriate to let it be resolved upstream.

Red Hat will continue to track the issue in the centralized upstream bug
tracker, and will review any bug fixes that become available for consideration
in future updates.

Thank you for the bug report.

Comment 4 Tethys 2008-07-01 20:10:10 UTC
Hmmm... so the upstream bug was opened 5 years ago, hasn't been touched in the
last 4 years, and doesn't seem to be directly related to this issue anyway
(neither it nor its dependencies mention import of Mozilla 1.x data). I guess
I'm not going to be holding out any great hopes of this being fixed in the near
future then :-(


Note You need to log in before you can comment on or make changes to this bug.