Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452804 - yum fails to upgrade thunderbird but reports success
Summary: yum fails to upgrade thunderbird but reports success
Keywords:
Status: CLOSED DUPLICATE of bug 477849
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Panu Matilainen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 07:57 UTC by Kir Kolyshkin
Modified: 2014-01-21 23:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2009-01-16 18:20:55 UTC


Attachments (Terms of Use)

Description Kir Kolyshkin 2008-06-25 07:57:42 UTC
Description of problem:

I have F9 system but thunderbird is from F8 (and the only difference in
thunderbird's version-release is f9 vs. f8). Yum thinks it needs to update
thunderbird, but the update process fails, but yum reports success:

[kir@localhost ~]$ sudo yum update
[sudo] password for kir: 
livna                                                    | 2.1 kB     00:00     
fedora                                                   | 2.4 kB     00:00     
fedora-debuginfo                                         | 1.9 kB     00:00     
fusion                                                   |  951 B     00:00     
updates                                                  | 2.3 kB     00:00     
updates-debuginfo                                        | 1.9 kB     00:00     
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package thunderbird.x86_64 0:2.0.0.14-1.fc9 set to be updated
--> Finished Dependency Resolution

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Updating:
 thunderbird             x86_64     2.0.0.14-1.fc9   fedora             23 M

Transaction Summary
=============================================================================
Install      0 Package(s)         
Update       1 Package(s)         
Remove       0 Package(s)         

Total size: 23 M
Is this ok [y/N]: y
Downloading Packages:
Running rpm_check_debug
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Updating       : thunderbird                                       [1/2] 
Error unpacking rpm package thunderbird-2.0.0.14-1.fc9.x86_64
error: unpacking of archive failed on file
/usr/lib64/thunderbird-2.0.0.14/dictionaries: cpio: rename

Updated: thunderbird.x86_64 0:2.0.0.14-1.fc9
Complete!


Version-Release number of selected component (if applicable):

[kir@localhost ~]$ rpm -q yum rpm fedora-release thunderbird
yum-3.2.16-2.fc9.noarch
rpm-4.4.2.3-2.fc9.x86_64
fedora-release-9-2.noarch
thunderbird-2.0.0.14-1.fc8.x86_64

How reproducible:

What I did is F8->F9 upgrade using yum. Then run 'yum update' again.

Steps to Reproduce:
1. Install F8
2. Install fedora-release-9
3. Run 'yum update' to update F8->F9
4. Run 'yum update' again to try to update firefox
  
Actual results:
See above

Expected results:
Updated thunderbird

Additional info:

Here's the directory which cpio complains about:
[kir@localhost ~]$ ls -ld /usr/lib64/thunderbird-2.0.0.14/dictionaries
drwxr-xr-x 2 root root 4096 2008-05-12 08:28
/usr/lib64/thunderbird-2.0.0.14/dictionaries
[kir@localhost ~]$ ls -l /usr/lib64/thunderbird-2.0.0.14/dictionaries
total 688
-rw-r--r-- 1 root root   2731 2005-07-16 22:45 en-US.aff
-rw-r--r-- 1 root root 696138 2006-08-01 20:15 en-US.dic

Here's the package that yum tries to install:
[kir@localhost ~]$ rpm -K
/var/cache/yum/fedora/packages/thunderbird-2.0.0.14-1.fc9.x86_64.rpm
/var/cache/yum/fedora/packages/thunderbird-2.0.0.14-1.fc9.x86_64.rpm: (sha1) dsa
sha1 md5 gpg OK
[kir@localhost ~]$ ls -l
/var/cache/yum/fedora/packages/thunderbird-2.0.0.14-1.fc9.x86_64.rpm
-rw-r--r-- 1 root root 23758742 2008-05-02 04:39
/var/cache/yum/fedora/packages/thunderbird-2.0.0.14-1.fc9.x86_64.rpm

Comment 1 Kir Kolyshkin 2008-06-25 08:00:04 UTC
In fact it looks like this is rather rpm problem, thus reassiging to 'rpm'.


[kir@localhost ~]$ sudo rpm -Uhv
/var/cache/yum/fedora/packages/thunderbird-2.0.0.14-1.fc9.x86_64.rpm
[sudo] password for kir: 
Preparing...                ########################################### [100%]
   1:thunderbird            ########################################### [100%]
error: unpacking of archive failed on file
/usr/lib64/thunderbird-2.0.0.14/dictionaries: cpio: rename failed - Is a directory

[kir@localhost ~]$ rpm -q rpm thunderbird
rpm-4.4.2.3-2.fc9.x86_64
thunderbird-2.0.0.14-1.fc8.x86_64

[kir@localhost ~]$ uname -a
Linux localhost.localdomain 2.6.25.6-55.fc9.x86_64 #1 SMP Tue Jun 10 16:05:21
EDT 2008 x86_64 x86_64 x86_64 GNU/Linux



Comment 2 seth vidal 2008-06-25 11:56:00 UTC
It looks like thunderbird is trying to change a dir to a symlink in the package.
Which will not work, at all, w/any rpm.


Comment 3 Panu Matilainen 2009-01-16 18:20:55 UTC
Changing dir to symlink is not going to work no matter what, so what's left is the false success reporting which makes this a dupe of 477849.

*** This bug has been marked as a duplicate of bug 477849 ***


Note You need to log in before you can comment on or make changes to this bug.