Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452778 - does not update all available packages
Summary: does not update all available packages
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-packagekit
Version: 10
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Robin Norwood
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-25 01:54 UTC by Jens Petersen
Modified: 2008-12-08 12:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-08 12:59:38 UTC


Attachments (Terms of Use)

Description Jens Petersen 2008-06-25 01:54:22 UTC
Description of problem:
I don't really understand why but I noticed that often gpk will not update
all available new packages at once.

How reproducible:
very often

Steps to Reproduce:
1. boot rawhide and login
2. see and review updates in gpk
3. apply updates
  
Actual results:
3. some time later (varies from minutes to hours) gpk comes up and says
"look there are updates".  (I know the repo has not changed since it is
a local mirror which syncs daily.)

Expected results:
3. all available updates to be included in one go.

Additional info:
This does not happen with direct yum updates.
I am pretty sure it also affects F9 and has been happening since the F9 devel cycle.

Comment 1 Richard Hughes 2008-06-25 14:05:16 UTC
Does "pkcon update" include all the updates? After you've done that - does
"pkcon get-updates" print anything?

Comment 2 Jens Petersen 2008-07-01 03:41:24 UTC
Hmm so I could be wrong now: I just tried in an install of rawhide from a tree
of 27June and it seems there were two packages uninstalled when I updated
to latest rawhide because of broken dependencies.

Is there some way for the UI to say these packages were installed and can't
be installed currently because of broken deps?

So now I am not sure if this is what I have been seeing all along, but
I think in the past it could not always have been broken deps for fedora updates.
I'll try to keep a eye on this going on and use pkcon.

Comment 3 Jens Petersen 2008-07-01 03:44:32 UTC
Just to clarify, thanks I used pkcon to work out the above.  Though
I have noticed such bad deps through PK before specially with rawhide.

(In reply to comment #2)
> [..] to say these packages were *not* installed and can't be [..]



Comment 4 Richard Hughes 2008-07-04 10:08:07 UTC
Right, you should have gotton a warning about the packages in the final screen
of the update viewer. Could you try again and grab the output from "pkmon" and
"gpk-update-viewer --verbose" -- thanks.


Comment 5 Jens Petersen 2008-07-17 08:30:24 UTC
I think we can probably close this for now since I am not seeing this problem
anymore
so I assumed it is already fixed.

I wonder if there is some way for the applet to wake up with desktop activitiy
faster -
it sometimes seems to take a long time, even hours, before notifying about
available updates?
Is that a related known issue?

Comment 6 Fedora Update System 2008-11-11 16:25:06 UTC
PackageKit-0.3.10-1.fc9,gnome-packagekit-0.3.10-1.fc9 has been submitted as an update for Fedora 9.
http://admin.fedoraproject.org/updates/PackageKit-0.3.10-1.fc9,gnome-packagekit-0.3.10-1.fc9

Comment 7 Fedora Update System 2008-11-12 02:56:46 UTC
PackageKit-0.3.10-1.fc9, gnome-packagekit-0.3.10-1.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit gnome-packagekit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9573

Comment 8 Fedora Update System 2008-11-21 11:01:11 UTC
PackageKit-0.3.10-2.fc9, gnome-packagekit-0.3.10-2.fc9 has been pushed to the Fedora 9 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update PackageKit gnome-packagekit'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F9/FEDORA-2008-9573

Comment 9 Bug Zapper 2008-11-26 02:27:56 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 10 development cycle.
Changing version to '10'.

More information and reason for this action is here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping

Comment 10 Fedora Update System 2008-12-08 12:59:22 UTC
PackageKit-0.3.10-2.fc9, gnome-packagekit-0.3.10-2.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.