Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452769 - maildrop should have courier-authlib support
Summary: maildrop should have courier-authlib support
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: maildrop
Version: 9
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Axel Thimm
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 456769 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 22:31 UTC by MePal
Modified: 2008-07-27 01:15 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-07 04:39:14 UTC


Attachments (Terms of Use)

Description MePal 2008-06-24 22:31:25 UTC
Current release of maildrop does not have courier-authlib built in, this makes
impossible to run the the maildrop with LDAP lookup.

If courier-authlib support is to hard to achieve (I read it from some other
bugs), better remove maildrop from repository - maildrop from fedora is not
using the version recommended by courier, which means every time I run yum
update it will overwrite my own installation until I manually bump up the
version (which makes my installation non-standard).

Comment 1 Johan Kok 2008-07-06 11:44:32 UTC
(In reply to comment #0)
> If courier-authlib support is to hard to achieve (I read it from some other
> bugs), better remove maildrop from repository - maildrop from fedora is not
> using the version recommended by courier,

courier-authlib is currently not packaged in fedora and can therefore not be used a dependency for 
maildrop. Compiling maildrop with courier-authlib is a 'nice to have' feature. Maildrop can use courier-
authlib to lookup some user data (for example, quota) but is quite usable without courier-authlib. The 
complete filtering and mail delivery engine can be used. Therefore, I can't see a reason for removal of the 
current package.

Comment 2 Axel Thimm 2008-07-07 04:39:14 UTC
I agree with Johan, just because we are not yet capable to enable all features
doesn't mean that we should remove the rest.

MePal, if you have it working, why not submit your courier-authlib package to
Fedora? Once this is in we can rebuild maildrop against it. There was already a
review that almost got passed (IIRC the submitter disappeared at some time),
e.g. there is no strong issue lice patents/licensing etc. preventing
courier-authlib to enter Fedora. Maybe the old submitted specifle still exists
to use it as a start.

Once courier-authlib is in Fedora, please reopen this bug, so I can rebuild
maildrop against it. Thanks!

Comment 3 Axel Thimm 2008-07-27 01:15:14 UTC
*** Bug 456769 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.