Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452748 - please reenable snd-pcsp
Summary: please reenable snd-pcsp
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: x86_64
OS: Linux
low
low
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 19:35 UTC by Stas Sergeev
Modified: 2008-07-03 03:17 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-07-03 03:17:51 UTC


Attachments (Terms of Use)

Description Stas Sergeev 2008-06-24 19:35:28 UTC
+++ This bug was initially created as a clone of Bug #448425 +++

+++ This bug was initially created as a clone of Bug #447039 +++

Description of problem:
After upgrading to kernel 2.6.26-0.13.rc2.git5.fc10.x86_64, system
sounds are gone. Instead, one can hear corresponding clicks emanating
from the PC speaker. dmesg reveals a backtrace which appears to be
related to this issue.

Version-Release number of selected component (if applicable):
kernel-2.6.26-0.13.rc2.git5.fc10.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. Upgrade to kernel-2.6.26-0.13.rc2.git5.fc10.x86_64
2. Reboot system.
3. Start GNOME session.
  
Actual results:
Click sounds from the PC speaker accompany system events.

Expected results:
GNOME sounds are played by the sound system.

Additional info:
- gnome-volume-control shows that the current audio device is pcsp.
- PulseAudio version is 0.9.10-1.fc9.
- ALSA version is 1.0.16-3.fc10.


-- Additional comment from davej@redhat.com on 2008-05-17 12:49 EST --
hmm, probably the addition of an ALSA driver for the PC speaker. This seems kind
of pointless, so I'll just turn it off.

Please check again with a build equal to or higher than
2.6.26-0.14.rc2.git5.fc10 when that appears.

Thanks.

-- Additional comment from jfrieben@hotmail.com on 2008-05-17 13:08 EST --
PC speaker support actually sounds nice. Shouldn't this issue be dealt
with upstream then? I don't mind opening a new bug report over there.

-- Additional comment from davej@redhat.com on 2008-05-17 13:27 EST --
Is this really useful ? From the Kconfig..

          If you don't have a sound card in your computer, you can include a
          driver for the PC speaker which allows it to act like a primitive
          sound card.

It's hard to imagine a machine without a sound card these days, given they
typically come onboard.  Hmm, though I suppose it's useful if you have a speaker
in your PC, and no external speakers.  The one concern I have is that adding
this driver will mean that everyone typically gets two ALSA output sources, and
which one gets picked by default is probably down to which driver gets loaded
first.  For a lot of people, that would be annoying if suddenly their music
comes out of their PC instead of their speakers.  Adding Lennart to the Cc,
perhaps he has some ideas on how to avoid that situation.

Another annoyance, is that this driver is unlikely to work well during some
periods of fedora development due to this..

#ifdef CONFIG_DEBUG_PAGEALLOC
        /* Well, CONFIG_DEBUG_PAGEALLOC makes the sound horrible. Lets alert */
        printk(KERN_WARNING "PCSP: CONFIG_DEBUG_PAGEALLOC is enabled, "
               "which may make the sound noisy.\n");
#endif

(We enable that option from time to time, though the build you tried didn't have
it turned back on yet).

I'll forward the backtrace upstream.

-- Additional comment from jfrieben@hotmail.com on 2008-05-18 06:20 EST --
Bug filed upstream at http://bugzilla.kernel.org/show_bug.cgi?id=10701

-- Additional comment from jfrieben@hotmail.com on 2008-05-18 10:57 EST --
Both audio devices register correctly on my system:

  card0/  cards   devices  oss/  pcsp@  timers
  card1/  CK804@  modules  pcm   seq/   version

It is furthermore possible to choose the default device by means of
gnome-sound-properties. So far, so good. It is definitely worthwile
to have some simple audio capability in case no external speakers
are available. Notebooks are of cause exempted herefrom, but in
general, this appears to be a compelling feature.
The clicks that I have describe seem to be due to some deficiency of
the NForce chipset of my Tyan K8E mainboard. In general, you expect
at least system sounds to be reproduced in a reasonable manner.

-- Additional comment from stsp@aknet.ru on 2008-05-26 14:50 EST --
Created an attachment (id=306697)
add snd-pcsp to blacklist


-- Additional comment from stsp@aknet.ru on 2008-05-26 14:53 EST --
Hi guys.

I second an opinion that having snd-pcsp
might be nice.
I've been suggested to just put it into
a blacklist rather than to disable completely,
so here's the patch.
Does such a solution look reasonable?

-- Additional comment from karsten@redhat.com on 2008-06-02 08:33 EST --
I've built hwdata-0.219 in rawhide with snd-pcsp blacklisted

Comment 1 Stas Sergeev 2008-06-24 19:38:55 UTC
So snd-pcsp is now blacklisted.
Also, since 2.6.26-rc7, snd-pcsp doesn't
prevent the pcspkr driver from being built.
This should be sufficient to avoid any surprise.
Can we have snd-pcsp enabled again?

Comment 2 Chuck Ebbert 2008-06-30 20:20:57 UTC
(In reply to comment #1)
> So snd-pcsp is now blacklisted.
> Also, since 2.6.26-rc7, snd-pcsp doesn't
> prevent the pcspkr driver from being built.
> This should be sufficient to avoid any surprise.
> Can we have snd-pcsp enabled again?

It might be okay in rawhide, but this bug is against F9 ???


Comment 3 Stas Sergeev 2008-07-01 03:20:17 UTC
OK sorry, it just initially was.


Note You need to log in before you can comment on or make changes to this bug.