Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 452740 - Kernel crash of Domain-0 while doing multiple dd's on a raid device.
Summary: Kernel crash of Domain-0 while doing multiple dd's on a raid device.
Keywords:
Status: CLOSED DUPLICATE of bug 452175
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen
Version: 5.2
Hardware: i386
OS: Linux
low
high
Target Milestone: rc
: ---
Assignee: Xen Maintainance List
QA Contact: Martin Jenner
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-06-24 18:25 UTC by Masoud Sharbiani
Modified: 2008-12-09 21:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2008-12-09 21:28:53 UTC


Attachments (Terms of Use)
Crash log, as captured from ttyS0 (deleted)
2008-06-24 18:25 UTC, Masoud Sharbiani
no flags Details

Description Masoud Sharbiani 2008-06-24 18:25:54 UTC
Description of problem:
I have a Dual P4 Xeon machine (32 bit Xeons), with hyperthreading enabled and 6
gigs of memory, with 6 IDE drives. 4 of these are on a separate controller card,
and setup as a soft raid device /dev/md0, mounted on /data. If I try and run
multiple 'dd if=/dev/zero of=/data', it crashes.


Version-Release number of selected component (if applicable):
2.6.18-92.el5xen

How reproducible:
Happens every time.

Steps to Reproduce:
1. Run multiple instances of dd if=/dev/zero of=/data/bigfatfile.$RANDOM on a
device.
2. Reducing the amount of memory available to Domain-0 seems to trigger it sooner.

  
Actual results:
System crashes.




Expected results:


Additional info:

Comment 1 Masoud Sharbiani 2008-06-24 18:25:54 UTC
Created attachment 310169 [details]
Crash log, as captured from ttyS0

Comment 2 Bill Burns 2008-12-09 21:28:53 UTC
Closing this as a duplicate of Bugzilla 452175 as it appears to be the same issue.

*** This bug has been marked as a duplicate of bug 452175 ***


Note You need to log in before you can comment on or make changes to this bug.